summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-24 07:57:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-12-24 07:57:49 +0000
commitfc67d3ad9a2903cc33e5cdaedaad51dd86a42236 (patch)
tree4ef72536a965fe220e71aea78b76b6bbbac2ed59 /Makefile
parentAdding upstream version 2.5. (diff)
downloadnvme-cli-fc67d3ad9a2903cc33e5cdaedaad51dd86a42236.tar.xz
nvme-cli-fc67d3ad9a2903cc33e5cdaedaad51dd86a42236.zip
Adding upstream version 2.7.1.upstream/2.7.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 10d16f0..7f44364 100644
--- a/Makefile
+++ b/Makefile
@@ -54,3 +54,11 @@ rpm:
debug:
meson ${BUILD-DIR} --buildtype=debug
ninja -C ${BUILD-DIR}
+
+.PHONY: static
+static:
+ meson ${BUILD-DIR} --buildtype=release \
+ --default-library=static -Dc_link_args="-static" \
+ --wrap-mode=forcefallback \
+ -Dlibnvme:tests=false -Dlibnvme:keyutils=disabled
+ ninja -C ${BUILD-DIR}