summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-11-05 18:23:26 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-11-05 18:23:26 +0000
commitfab3f41b7b3f080c215157a026ee6bc7efbfe968 (patch)
treef0fafb0805c3eb11eb2a278f9f8058376c8f0f2b /Makefile
parentAdding upstream version 2.1.2. (diff)
downloadnvme-cli-upstream/2.2.1.tar.xz
nvme-cli-upstream/2.2.1.zip
Adding upstream version 2.2.1.upstream/2.2.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 085adf8..10d16f0 100644
--- a/Makefile
+++ b/Makefile
@@ -34,6 +34,10 @@ endif
install dist: ${BUILD-DIR}
cd ${BUILD-DIR} && meson $@
+.PHONY: uninstall
+uninstall:
+ cd ${BUILD-DIR} && meson --internal uninstall
+
.PHONY: test
test: ${BUILD-DIR}
ninja -C ${BUILD-DIR} $@
@@ -45,3 +49,8 @@ rpm:
-Dsystemddir=$(shell rpm --eval '%{_unitdir}') \
-Ddocs=man -Ddocs-build=true
rpmbuild -ba ${BUILD-DIR}/nvme.spec --define "_builddir ${BUILD-DIR}" -v
+
+.PHONY: debug
+debug:
+ meson ${BUILD-DIR} --buildtype=debug
+ ninja -C ${BUILD-DIR}