summaryrefslogtreecommitdiffstats
path: root/ccan/meson.build
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-07-14 18:27:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-07-16 15:11:56 +0000
commit6197903bd42478987516bc4cc3f0769488a37065 (patch)
tree508d399340039960289dd1d96696db7c56c22321 /ccan/meson.build
parentAdding upstream version 1.16. (diff)
downloadnvme-cli-6197903bd42478987516bc4cc3f0769488a37065.tar.xz
nvme-cli-6197903bd42478987516bc4cc3f0769488a37065.zip
Adding upstream version 2.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'ccan/meson.build')
-rw-r--r--ccan/meson.build10
1 files changed, 10 insertions, 0 deletions
diff --git a/ccan/meson.build b/ccan/meson.build
new file mode 100644
index 0000000..7573265
--- /dev/null
+++ b/ccan/meson.build
@@ -0,0 +1,10 @@
+sources += files([
+ 'ccan/list/list.c',
+ 'ccan/str/debug.c',
+ 'ccan/str/str.c',
+])
+
+if get_option('buildtype') == 'debug'
+ add_project_arguments('-DCCAN_LIST_DEBUG=1', language : ['c', 'cpp'])
+ add_project_arguments('-DCCAN_STR_DEBUG=1', language : ['c', 'cpp'])
+endif