summaryrefslogtreecommitdiffstats
path: root/tests/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-07-14 18:27:59 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-07-16 15:11:56 +0000
commit6197903bd42478987516bc4cc3f0769488a37065 (patch)
tree508d399340039960289dd1d96696db7c56c22321 /tests/Makefile
parentAdding upstream version 1.16. (diff)
downloadnvme-cli-6197903bd42478987516bc4cc3f0769488a37065.tar.xz
nvme-cli-6197903bd42478987516bc4cc3f0769488a37065.zip
Adding upstream version 2.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/Makefile')
-rw-r--r--tests/Makefile48
1 files changed, 0 insertions, 48 deletions
diff --git a/tests/Makefile b/tests/Makefile
deleted file mode 100644
index c0f9f31..0000000
--- a/tests/Makefile
+++ /dev/null
@@ -1,48 +0,0 @@
-###############################################################################
-#
-# Makefile : Allows user to run testcases, generate documentation, and
-# perform static code analysis.
-#
-###############################################################################
-
-NOSE2_OPTIONS="--verbose"
-
-help: all
-
-all:
- @echo "Usage:"
- @echo
- @echo " make run - Run all testcases."
- @echo " make doc - Generate Documentation."
- @echo " make cleanall - removes *pyc, documentation."
- @echo " make static_check- runs pep8, flake8, pylint on code."
-
-doc:
- @epydoc -v --output=Documentation *.py
-
-run:
- @for i in `ls *.py`; \
- do \
- echo "Running $${i}"; \
- TESTCASE_NAME=`echo $${i} | cut -f 1 -d '.'`; \
- nose2 ${NOSE2_OPTIONS} $${TESTCASE_NAME}; \
- done
-
-static_check:
- @for i in `ls *.py`; \
- do \
- echo "Pylint :- " ; \
- printf "%10s " $${i}; \
- pylint $${i} 2>&1 | grep "^Your code" | awk '{print $$7}';\
- echo "--------------------------------------------";\
- pep8 $${i}; \
- echo "pep8 :- "; \
- echo "flake8 :- "; \
- flake8 $${i}; \
- done
-
-cleanall: clean
- @rm -fr *.pyc Documentation
-
-clean:
- @rm -fr *.pyc