summaryrefslogtreecommitdiffstats
path: root/tests
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-01-31 04:13:00 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-01-31 04:13:00 +0000
commitdc3f3471f8a00ce0c8fb4cbf2a31e299696f3bbc (patch)
treee97b4f25c511372d73bdd96c389c5f468d99138a /tests
parentAdding upstream version 2.2.1. (diff)
downloadnvme-cli-dc3f3471f8a00ce0c8fb4cbf2a31e299696f3bbc.tar.xz
nvme-cli-dc3f3471f8a00ce0c8fb4cbf2a31e299696f3bbc.zip
Adding upstream version 2.3.upstream/2.3
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rw-r--r--tests/README11
-rw-r--r--tests/meson.build9
-rw-r--r--unit/test-uint128.c (renamed from tests/test-uint128.c)0
3 files changed, 9 insertions, 11 deletions
diff --git a/tests/README b/tests/README
index 14b24e5..a5fa708 100644
--- a/tests/README
+++ b/tests/README
@@ -1,13 +1,20 @@
nvmetests
=========
- This contains NVMe unit tests framework. The purpose of this framework
+ This contains a NVMe tests framework. The purpose of this framework
to use nvme cli and test various supported commands and scenarios for
NVMe device.
- In current implementation this framework uses nvme cli to
+ In current implementation this framework uses nvme-cli to
interact with underlying controller/namespace.
+ Note these tests expect to run against real hardware and will
+ read and write data to /dev/nvme0!
+
+ DO NOT RUN THEM IF YOU DO NOT KNOW WHAT YOU ARE DOING!
+
+ You have been warned.
+
1. Common Package Dependencies
------------------------------
diff --git a/tests/meson.build b/tests/meson.build
index 6f17137..630f35d 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -55,15 +55,6 @@ if runtests.found()
endforeach
endif
-test_uint128 = executable(
- 'test-uint128',
- ['test-uint128.c', '../util/types.c'],
- include_directories: [incdir, '..'],
- dependencies: [libnvme_dep],
-)
-
-test('uint128', test_uint128)
-
python_module = import('python')
python = python_module.find_installation('python3')
diff --git a/tests/test-uint128.c b/unit/test-uint128.c
index 6301a38..6301a38 100644
--- a/tests/test-uint128.c
+++ b/unit/test-uint128.c