summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/control9
-rwxr-xr-xdebian/rules20
2 files changed, 28 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index 28e18a0..472282f 100644
--- a/debian/control
+++ b/debian/control
@@ -27,3 +27,12 @@ Description: NVMe management tool
(PCIe).
.
The nvme-cli tool provides management functions for these devices.
+
+Package: nvme-cli-udeb
+Section: debian-installer
+Package-Type: udeb
+Architecture: any
+Depends:
+ ${misc:Depends},
+ ${shlibs:Depends},
+Description: NVMe management tool
diff --git a/debian/rules b/debian/rules
index 70a49a5..c84c9b6 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,8 +5,26 @@ export DEB_BUILD_MAINT_OPTIONS=hardening=+all
%:
dh ${@}
+execute_after_dh_auto_clean:
+ rm -rf build-udeb
+
+execute_after_dh_auto_configure:
+ mkdir -p build-udeb
+ find . -maxdepth 1 -mindepth 1 -and -not -name debian -and -not -name ".git*" -and -not -name ".pc*" -exec cp -a {} build-udeb \;
+ dh_auto_configure --builddirectory build-udeb
+
+execute_after_dh_auto_build:
+ DEB_CFLAGS_MAINT_APPEND=-Os dh_auto_build \
+ --reload-all-buildenv-variables \
+ --builddirectory build-udeb \
+ -- \
+ nvme HAVE_SYSTEMD=no LIBHUGETLBFS=no
+
+execute_after_dh_auto_install:
+ $(MAKE) -C build-udeb install-bin DESTDIR=$(CURDIR)/debian/nvme-cli-udeb PREFIX=/usr
+
override_dh_auto_install:
- dh_auto_install -- PREFIX=/usr UDEVDIR=/lib/udev SYSTEMDDIR=/lib/systemd
+ dh_auto_install -- DESTDIR=$(CURDIR)/debian/nvme-cli PREFIX=/usr UDEVDIR=/lib/udev SYSTEMDDIR=/lib/systemd
# removing unique files
rm -f debian/nvme-cli/etc/nvme/hostid