summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 7f44364..1838a0f 100644
--- a/Makefile
+++ b/Makefile
@@ -10,18 +10,18 @@ NAME := nvme
BUILD-DIR := .build
${BUILD-DIR}:
- meson $@
+ meson setup $@
@echo "Configuration located in: $@"
@echo "-------------------------------------------------------"
.PHONY: ${NAME}
${NAME}: ${BUILD-DIR}
- ninja -C ${BUILD-DIR}
+ meson compile -C ${BUILD-DIR}
.PHONY: clean
clean:
ifneq ("$(wildcard ${BUILD-DIR})","")
- ninja -C ${BUILD-DIR} -t $@
+ meson compile --clean -C ${BUILD-DIR}
endif
.PHONY: purge