summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 10d16f0..7f44364 100644
--- a/Makefile
+++ b/Makefile
@@ -54,3 +54,11 @@ rpm:
debug:
meson ${BUILD-DIR} --buildtype=debug
ninja -C ${BUILD-DIR}
+
+.PHONY: static
+static:
+ meson ${BUILD-DIR} --buildtype=release \
+ --default-library=static -Dc_link_args="-static" \
+ --wrap-mode=forcefallback \
+ -Dlibnvme:tests=false -Dlibnvme:keyutils=disabled
+ ninja -C ${BUILD-DIR}