summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-10 09:26:03 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-06-10 09:27:49 +0000
commit50e0137673dc400aaab7da461bb3d12caf6a960b (patch)
tree656ca59665bc2071433c2f9cee61edfcfd2237c1
parentReleasing debian version 2.2.1-2. (diff)
downloadnvme-stas-50e0137673dc400aaab7da461bb3d12caf6a960b.tar.xz
nvme-stas-50e0137673dc400aaab7da461bb3d12caf6a960b.zip
Merging upstream version 2.2.2.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--NEWS.md6
-rw-r--r--meson.build2
-rw-r--r--staslib/trid.py7
3 files changed, 13 insertions, 2 deletions
diff --git a/NEWS.md b/NEWS.md
index bdda8d3..5fa3fd4 100644
--- a/NEWS.md
+++ b/NEWS.md
@@ -1,5 +1,11 @@
# STorage Appliance Services (STAS)
+## Changes with release 2.2.2
+
+Bug fixes:
+
+* Fix migration of old "last known config" to new format. Old TID objects did not contain a `_cfg` member. Therefore, one needs to check for its existence (through introspection) before blindly trying to access it.
+
## Changes with release 2.2.1
Added a few more unit and coverage tests. Fixed the following bugs.
diff --git a/meson.build b/meson.build
index b84e3d1..bf2dda5 100644
--- a/meson.build
+++ b/meson.build
@@ -9,7 +9,7 @@
project(
'nvme-stas',
meson_version: '>= 0.53.0',
- version: '2.2.1',
+ version: '2.2.2',
license: 'Apache-2.0',
default_options: [
'buildtype=release',
diff --git a/staslib/trid.py b/staslib/trid.py
index ea40b7d..d9a05ba 100644
--- a/staslib/trid.py
+++ b/staslib/trid.py
@@ -106,7 +106,12 @@ class TID: # pylint: disable=too-many-instance-attributes
'host-traddr': self.host_traddr,
'host-iface': self.host_iface,
}
- data.update(self._cfg)
+
+ # When migrating an old last known config, the "_cfg" member may
+ # not exist. Therefor retrive it with getattr() to avoid a crash.
+ cfg = getattr(self, '_cfg', None)
+ if cfg:
+ data.update(cfg)
return data
def __str__(self):