summaryrefslogtreecommitdiffstats
path: root/bump-ver.sh
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 15:57:28 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-05-05 15:57:28 +0000
commita5283f584122bbcfb9085d46f6efe18d45440719 (patch)
tree6f516f7d908a9852650b2f48f50818e0c1a3b3e0 /bump-ver.sh
parentInitial commit. (diff)
downloadnvmetcli-upstream/0.8.tar.xz
nvmetcli-upstream/0.8.zip
Adding upstream version 0.8.upstream/0.8upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'bump-ver.sh')
-rwxr-xr-xbump-ver.sh25
1 files changed, 25 insertions, 0 deletions
diff --git a/bump-ver.sh b/bump-ver.sh
new file mode 100755
index 0000000..21f7df3
--- /dev/null
+++ b/bump-ver.sh
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# Bump the version and cut a release. Can't be called release.sh because
+# that would conflict with the make release rule in the makefile.
+#
+
+VER=$1
+
+set -e
+set +x
+
+if [ -z "$VER" ]; then
+ echo "usage: $0 version" >&2
+ exit 1
+fi
+
+make clean
+sed -i "s/version =.*,/version = $VER,/" setup.py
+git add setup.py
+git commit -m "bump version to v$VER"
+
+git tag -s "v$VER" -m "nvmetcli release v$VER"
+
+make release
+(cd dist && gpg --armor --detach-sign nvmetcli-$VER.tar.gz)