summaryrefslogtreecommitdiffstats
path: root/bump-ver.sh
diff options
context:
space:
mode:
Diffstat (limited to '')
-rwxr-xr-xbump-ver.sh25
1 files changed, 25 insertions, 0 deletions
diff --git a/bump-ver.sh b/bump-ver.sh
new file mode 100755
index 0000000..21f7df3
--- /dev/null
+++ b/bump-ver.sh
@@ -0,0 +1,25 @@
+#!/bin/sh
+#
+# Bump the version and cut a release. Can't be called release.sh because
+# that would conflict with the make release rule in the makefile.
+#
+
+VER=$1
+
+set -e
+set +x
+
+if [ -z "$VER" ]; then
+ echo "usage: $0 version" >&2
+ exit 1
+fi
+
+make clean
+sed -i "s/version =.*,/version = $VER,/" setup.py
+git add setup.py
+git commit -m "bump version to v$VER"
+
+git tag -s "v$VER" -m "nvmetcli release v$VER"
+
+make release
+(cd dist && gpg --armor --detach-sign nvmetcli-$VER.tar.gz)