summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2016-12-11 13:21:27 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2016-12-11 13:31:09 +0000
commitef124f86b4c1af391c70007f2a2658a24e265271 (patch)
tree92eec333ae554f76402c3a5155116c9d1fcfb95d
parentReleasing debian version 20161101-lts1-1. (diff)
downloadopen-infrastructure-compute-tools-ef124f86b4c1af391c70007f2a2658a24e265271.tar.xz
open-infrastructure-compute-tools-ef124f86b4c1af391c70007f2a2658a24e265271.zip
Merging upstream version 20161101-lts2.
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
-rw-r--r--CHANGELOG.txt25
-rw-r--r--Makefile2
-rw-r--r--README.txt11
-rw-r--r--VERSION.txt2
-rwxr-xr-xlib/container/list37
-rwxr-xr-xlib/container/remove2
-rw-r--r--share/doc/HOST-SETUP.txt8
-rw-r--r--share/man/container-auto.1.txt9
-rw-r--r--share/man/container-console.1.txt9
-rw-r--r--share/man/container-create-debconf.1.txt9
-rw-r--r--share/man/container-create-debootstrap.1.txt9
-rw-r--r--share/man/container-create.1.txt9
-rw-r--r--share/man/container-list.1.txt9
-rw-r--r--share/man/container-remove.1.txt9
-rw-r--r--share/man/container-restart.1.txt9
-rw-r--r--share/man/container-shell.1.txt9
-rw-r--r--share/man/container-start.1.txt9
-rw-r--r--share/man/container-status.1.txt9
-rw-r--r--share/man/container-stop.1.txt9
-rw-r--r--share/man/container-tools.7.txt19
-rw-r--r--share/man/container-version.1.txt9
-rw-r--r--share/man/container.1.txt12
-rwxr-xr-xshare/scripts/debconf13
-rwxr-xr-xshare/scripts/debconf.d/0003-debconf4
-rwxr-xr-xshare/scripts/debootstrap2
25 files changed, 160 insertions, 94 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index ebe3da7..ff7e432 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,3 +1,27 @@
+2016-12-10 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+
+ * Releasing version 20161101-lts2.
+
+ [Daniel Baumann]
+ * Removing empty line at the end of the changelog file.
+ * Adding mandatory inclusion of /etc/network/interfaces.d files in host-setup documentation, thanks to Richard Nelson <unixabg@gmail.com>.
+ * Removing support for Debian 8 (jessie) in debconf container create script.
+ * Updating development section in container-tools manpage.
+ * Updating development section in readme file.
+ * Avoid repeating ipv4 address of the previous container in container list command.
+ * Fail to find container in remove command only when both the rootfs and the config are gone already.
+ * Correcting syntax in usage message of container create scripts.
+ * Updating contact section in manpages.
+ * Harmonizing manpage markup.
+ * Removing libui-dialog-perl from includes in debconf container create script.
+ * Minimizing included packages by default in debconf container create script.
+ * Adding note about configuration files in container manpage.
+ * Harmonizing markup of email addresses in manpages.
+ * Completing usage message in container list command.
+ * Adding trailing line in full format for container list command.
+ * Removing half-finished multi-address handling in container list command.
+ * Removing not yet used hooks directory in /etc/container-tools.
+
2016-11-01 Daniel Baumann <daniel.baumann@open-infrastructure.net>
* Releasing version 20161101-lts1.
@@ -275,4 +299,3 @@
2016-03-01 Daniel Baumann <daniel.baumann@open-infrastructure.net>
* Releasing version 20160301.
-
diff --git a/Makefile b/Makefile
index 94289f2..8e0257f 100644
--- a/Makefile
+++ b/Makefile
@@ -55,7 +55,6 @@ build: share/man/*.txt
install: build
mkdir -p $(DESTDIR)/etc/${SOFTWARE}/config
mkdir -p $(DESTDIR)/etc/${SOFTWARE}/debconf
- mkdir -p $(DESTDIR)/etc/${SOFTWARE}/hooks
mkdir -p $(DESTDIR)/usr/bin
cp -r bin/* $(DESTDIR)/usr/bin
@@ -155,7 +154,6 @@ uninstall:
rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/etc/${SOFTWARE}/config || true
rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/etc/${SOFTWARE}/debconf || true
- rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/etc/${SOFTWARE}/hooks || true
rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/etc/${SOFTWARE} || true
rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/etc || true
diff --git a/README.txt b/README.txt
index 2b927f2..0c7aa15 100644
--- a/README.txt
+++ b/README.txt
@@ -43,14 +43,19 @@ systemd-nspawn.
4. Development
--------------
-Bug reports, feature requests, and patches are welcome via Debian Bug Tracking System:
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List:
- * https://bugs.debian.org
+ * https://lists.open-infrastructure.net/listinfo/software
-Please base them against the 'next' Git branch using common sense:
+Please base patches against the 'next' Git branch using common sense:
* https://www.kernel.org/doc/Documentation/SubmittingPatches
+Debian specific bugs can also be reported in the Debian Bug Tracking System:
+
+ * https://bugs.debian.org
+
5. Known Limitations
--------------------
diff --git a/VERSION.txt b/VERSION.txt
index 3fa429d..5f42ddb 100644
--- a/VERSION.txt
+++ b/VERSION.txt
@@ -1 +1 @@
-20161101-lts1
+20161101-lts2
diff --git a/lib/container/list b/lib/container/list
index d522623..9b93173 100755
--- a/lib/container/list
+++ b/lib/container/list
@@ -86,7 +86,7 @@ Parameters ()
Usage ()
{
- echo "Usage: container ${COMMAND} -a|--all --format FORMAT -s|--started -t|--stopped" >&2
+ echo "Usage: container ${COMMAND} [-a|--all] [--format FORMAT] [-h|--host HOSTNAME] [-o|--other] [-s|--started] [-t|--stopped]" >&2
exit 1
}
@@ -125,21 +125,7 @@ Show ()
;;
full)
- FIRST_LINE="true"
-
- for ADDRESS in ${ADDRESSES}
- do
- case "${FIRST_LINE}" in
- true)
- FIRST_LINE="false"
- printf "%-80s %-29s\n" "${STATUS} ${BLUE}${CONTAINER}${NORMAL}" "${YELLOW}${ADDRESS}${NORMAL}"
- ;;
-
- *)
- printf "%-80s %-29s\n" "" "${ADDRESS}"
- ;;
- esac
- done
+ printf "%-80s %-29s\n" "${STATUS} ${BLUE}${CONTAINER}${NORMAL}" "${YELLOW}${ADDRESS}${NORMAL}"
;;
esac
}
@@ -183,12 +169,14 @@ do
;;
esac
+ ADDRESS=""
+
if [ -e "${MACHINES}/${CONTAINER}/etc/network/interfaces" ]
then
- ADDRESSES="$(awk '/address/ { print $2 }' ${MACHINES}/${CONTAINER}/etc/network/interfaces)"
+ ADDRESS="$(awk '/address/ { print $2 }' ${MACHINES}/${CONTAINER}/etc/network/interfaces | head -n1)"
fi
- ADDRESSES="${ADDRESSES:-n/a}"
+ ADDRESS="${ADDRESS:-n/a}"
if echo ${LIST} | grep -qs all
then
@@ -207,3 +195,16 @@ do
fi
done
done
+
+case "${FORMAT}" in
+ full)
+
+cat << EOF
+--------------------------------------------------------------------------------
+EOF
+
+ ;;
+
+ short)
+ ;;
+esac
diff --git a/lib/container/remove b/lib/container/remove
index 843e9c3..04e7d30 100755
--- a/lib/container/remove
+++ b/lib/container/remove
@@ -82,7 +82,7 @@ then
Usage
fi
-if [ ! -e "${MACHINES}/${NAME}" ]
+if [ ! -e "${MACHINES}/${NAME}" ] && [ ! -e "${CONFIG}/${NAME}.conf" ]
then
echo "'${NAME}': no such container" >&2
exit 1
diff --git a/share/doc/HOST-SETUP.txt b/share/doc/HOST-SETUP.txt
index a5aca94..c77f829 100644
--- a/share/doc/HOST-SETUP.txt
+++ b/share/doc/HOST-SETUP.txt
@@ -47,6 +47,8 @@ sysctl -p
cat > /etc/network/interfaces << EOF
# /etc/network/interfaces
+source /etc/network/interfaces.d/*
+
auto lo
iface lo inet loopback
@@ -67,6 +69,8 @@ EOF
cat > /etc/network/interfaces << EOF
# /etc/network/interfaces
+source /etc/network/interfaces.d/*
+
auto lo
iface lo inet loopback
@@ -94,6 +98,8 @@ EOF
cat > /etc/network/interfaces << EOF
# /etc/network/interfaces
+source /etc/network/interfaces.d/*
+
auto lo
iface lo inet loopback
@@ -120,6 +126,8 @@ EOF
cat > /etc/network/interfaces << EOF
# /etc/network/interfaces
+source /etc/network/interfaces.d/*
+
auto lo
iface lo inet loopback
diff --git a/share/man/container-auto.1.txt b/share/man/container-auto.1.txt
index a1f1ab3..0eb76d2 100644
--- a/share/man/container-auto.1.txt
+++ b/share/man/container-auto.1.txt
@@ -68,9 +68,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container-console.1.txt b/share/man/container-console.1.txt
index 410ff92..7b25125 100644
--- a/share/man/container-console.1.txt
+++ b/share/man/container-console.1.txt
@@ -62,9 +62,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container-create-debconf.1.txt b/share/man/container-create-debconf.1.txt
index 9593415..a51dfef 100644
--- a/share/man/container-create-debconf.1.txt
+++ b/share/man/container-create-debconf.1.txt
@@ -141,9 +141,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container-create-debootstrap.1.txt b/share/man/container-create-debootstrap.1.txt
index 7f7d8fb..9de3f94 100644
--- a/share/man/container-create-debootstrap.1.txt
+++ b/share/man/container-create-debootstrap.1.txt
@@ -83,9 +83,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container-create.1.txt b/share/man/container-create.1.txt
index 4fe592f..3ab7419 100644
--- a/share/man/container-create.1.txt
+++ b/share/man/container-create.1.txt
@@ -93,9 +93,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container-list.1.txt b/share/man/container-list.1.txt
index 8ac59c2..6e08d25 100644
--- a/share/man/container-list.1.txt
+++ b/share/man/container-list.1.txt
@@ -82,9 +82,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container-remove.1.txt b/share/man/container-remove.1.txt
index cad779f..4c3577f 100644
--- a/share/man/container-remove.1.txt
+++ b/share/man/container-remove.1.txt
@@ -71,9 +71,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container-restart.1.txt b/share/man/container-restart.1.txt
index eda0174..2aed923 100644
--- a/share/man/container-restart.1.txt
+++ b/share/man/container-restart.1.txt
@@ -62,9 +62,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container-shell.1.txt b/share/man/container-shell.1.txt
index f7e0270..38a8034 100644
--- a/share/man/container-shell.1.txt
+++ b/share/man/container-shell.1.txt
@@ -65,9 +65,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container-start.1.txt b/share/man/container-start.1.txt
index bf1d8de..64c4b3c 100644
--- a/share/man/container-start.1.txt
+++ b/share/man/container-start.1.txt
@@ -65,9 +65,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container-status.1.txt b/share/man/container-status.1.txt
index f1688dc..8da969f 100644
--- a/share/man/container-status.1.txt
+++ b/share/man/container-status.1.txt
@@ -62,9 +62,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container-stop.1.txt b/share/man/container-stop.1.txt
index 8b864d6..24fcd93 100644
--- a/share/man/container-stop.1.txt
+++ b/share/man/container-stop.1.txt
@@ -62,9 +62,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container-tools.7.txt b/share/man/container-tools.7.txt
index 2e71b05..b6c83d6 100644
--- a/share/man/container-tools.7.txt
+++ b/share/man/container-tools.7.txt
@@ -37,7 +37,6 @@ container-tools provides the system integration for managing containers using sy
DOWNLOAD
--------
-
* Upstream Releases: https://files.open-infrastructure.net/software/container-tools/upstream
* Upstream Sources: https://sources.open-infrastructure.net/software/container-tools
* Debian Releases: https://files.open-infrastructure.net/software/container-tools/debian
@@ -49,32 +48,33 @@ INSTALLATION
SOURCE
~~~~~~
-
1. sudo apt install asciidoc git docbook-xml docbook-xsl libxml2-utils make xsltproc dbus systemd-container
2. git clone https://sources.open-infrastructure.net/software/container-tools
3. cd container-tools && sudo make install
DEBIAN 9 (STRETCH) AND NEWER
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-
* sudo apt install container-tools
DEVELOPMENT
-----------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List:
-Bug reports, feature requests, and patches are welcome via Debian Bug Tracking System:
+ * https://lists.open-infrastructure.net/listinfo/software
- * https://bugs.debian.org
-
-Please base them against the 'next' Git branch using common sense:
+Please base patches against the 'next' Git branch using common sense:
* https://www.kernel.org/doc/Documentation/SubmittingPatches
+Debian specific bugs can also be reported in the Debian Bug Tracking System:
+
+ * https://bugs.debian.org
+
KNOWN LIMITATIONS
-----------------
-
* This version of container-tools currently do not work with systemd-networkd and depend on ifupdown.
* Using overlay, the upper directory can not be an NFS mount due to limitations in Linux' overlay filesystem,
see https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/tree/Documentation/filesystems/overlayfs.txt
@@ -82,7 +82,6 @@ KNOWN LIMITATIONS
USAGE
-----
-
*Create a new container:*::
sudo container create -n NAME
@@ -106,7 +105,6 @@ See container(1) for a list of all container commands.
LINKS
-----
-
*2016-02-24: Systemd vs. Docker*::
https://lwn.net/Articles/676831/
@@ -131,5 +129,4 @@ LINKS
AUTHORS
-------
-
* Daniel Baumann <daniel.baumann@open-infrastructure.net>
diff --git a/share/man/container-version.1.txt b/share/man/container-version.1.txt
index 5e50ad4..d9f37f9 100644
--- a/share/man/container-version.1.txt
+++ b/share/man/container-version.1.txt
@@ -59,9 +59,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/man/container.1.txt b/share/man/container.1.txt
index 78a7d68..880d990 100644
--- a/share/man/container.1.txt
+++ b/share/man/container.1.txt
@@ -81,6 +81,9 @@ FILES
-----
The following files are used:
+*/etc/container-tools*::
+ Container configuration files.
+
*/usr/bin/container*, */usr/bin/cnt*::
Container program.
@@ -111,9 +114,12 @@ HOMEPAGE
More information about container-tools and the Open Infrastructure project can be found on the homepage at https://open-infrastructure.net.
-BUGS
-----
-Bugs can be reported by sending a bug report to the Debian Bug Tracking System at https://bugs.debian.org.
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
AUTHORS
diff --git a/share/scripts/debconf b/share/scripts/debconf
index 4878d98..69282ba 100755
--- a/share/scripts/debconf
+++ b/share/scripts/debconf
@@ -81,7 +81,7 @@ Parameters ()
Usage ()
{
- echo "Usage: container create -n|--name NAME -s|--script ${SCRIPT} [-p|--preseed-file FILE]" >&2
+ echo "Usage: container create -n|--name NAME -s|--script ${SCRIPT} -- [-p|--preseed-file FILE]" >&2
exit 1
}
@@ -235,17 +235,6 @@ Debootstrap ()
INCLUDE="${INCLUDE},apt-transport-https,ca-certificates"
fi
- # FIXME: trim down, debootstrap variants?
- case "${MODE}" in
- debian)
- INCLUDE="${INCLUDE},ifupdown,locales,libui-dialog-perl,dialog,isc-dhcp-client,netbase,net-tools,iproute,wget"
- ;;
-
- progress-linux)
- INCLUDE="${INCLUDE},apt-utils,ifupdown,locales-all,libui-dialog-perl,dialog,isc-dhcp-client,netbase,net-tools,iproute,openssh-server,wget"
- ;;
- esac
-
mkdir -p "$(dirname ${DIRECTORY})"
debootstrap --verbose --arch=${ARCHITECTURE} --components=${PARENT_ARCHIVE_AREAS} --include=${INCLUDE} \
${PARENT_DISTRIBUTION} "${DIRECTORY}" ${PARENT_MIRROR}
diff --git a/share/scripts/debconf.d/0003-debconf b/share/scripts/debconf.d/0003-debconf
index c0944fa..77dc030 100755
--- a/share/scripts/debconf.d/0003-debconf
+++ b/share/scripts/debconf.d/0003-debconf
@@ -32,8 +32,8 @@ Distribution ()
then
case "${MODE}" in
debian)
- db_subst cnt-debconf/distribution CHOICES "Debian GNU/Linux 8 \"jessie\", Debian GNU/Linux 9 \"stretch\", Debian GNU/Linux unstable/sid"
- db_subst cnt-debconf/distribution CHOICES_C "jessie, stretch, sid"
+ db_subst cnt-debconf/distribution CHOICES "Debian GNU/Linux 9 \"stretch\", Debian GNU/Linux unstable/sid"
+ db_subst cnt-debconf/distribution CHOICES_C "stretch, sid"
db_set cnt-debconf/distribution stretch
db_fset cnt-debconf/distribution seen false
diff --git a/share/scripts/debootstrap b/share/scripts/debootstrap
index 1ead471..e04f32d 100755
--- a/share/scripts/debootstrap
+++ b/share/scripts/debootstrap
@@ -95,7 +95,7 @@ Parameters ()
Usage ()
{
- echo "Usage: container create -n|--name NAME -s|--script ${SCRIPT} [-a|--architecture ARCHITECTURE] [-d|--distribution DISTRIBUTION] [-m|--mirror MIRROR] [-p|--password PASSWORD}" >&2
+ echo "Usage: container create -n|--name NAME -s|--script ${SCRIPT} -- [-a|--architecture ARCHITECTURE] [-d|--distribution DISTRIBUTION] [-m|--mirror MIRROR] [-p|--password PASSWORD}" >&2
exit 1
}