summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-07-24 18:45:13 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-07-24 18:55:55 +0000
commitf36095ed361afeaad2f44720ada816ec3bee7cb6 (patch)
treef456942861d9aaa471e870573ce2c3932fb30c48
parentReleasing progress-linux version 20210630-1. (diff)
downloadopen-infrastructure-compute-tools-f36095ed361afeaad2f44720ada816ec3bee7cb6.tar.xz
open-infrastructure-compute-tools-f36095ed361afeaad2f44720ada816ec3bee7cb6.zip
Merging upstream version 20210724.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--CHANGELOG.txt16
-rw-r--r--Makefile2
-rw-r--r--VERSION.txt2
-rwxr-xr-xlibexec/container/stop2
-rw-r--r--share/bash-completion/container4
-rw-r--r--share/config/container.conf.in2
-rw-r--r--share/doc/host-setup.txt (renamed from share/doc/HOST-SETUP.txt)34
-rw-r--r--share/logrotate/container2
-rw-r--r--share/procps/zz-container.conf2
-rwxr-xr-xshare/scripts/debconf8
-rwxr-xr-xshare/scripts/debootstrap4
-rw-r--r--share/sudo/container-shell2
-rw-r--r--share/systemd/container-auto.service2
-rw-r--r--share/systemd/container@.service2
14 files changed, 56 insertions, 28 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index 043bd62..492d5f4 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,3 +1,19 @@
+2021-07-24 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+
+ * Releasing version 20210724.
+
+ [ Daniel Baumann ]
+ * Removing note about ipv4 forwarding, this is not actually required (anymore).
+ * Correcting wording in host setup documentation.
+ * Adding @FILE@ replacement variables in preseed files.
+ * Also removing lock file when force-stopping a container.
+ * Exporting IP variables to be used in host commands.
+ * Using lower-case filename for host-setup documentation.
+ * Improving section titles in host-setup documentation.
+ * Harmonizing first line in comments of non-shebang files.
+ * Using fixme rather than todo in source files.
+ * Improving comments in debootstrap script.
+
2021-06-30 Daniel Baumann <daniel.baumann@open-infrastructure.net>
* Releasing version 20210630.
diff --git a/Makefile b/Makefile
index 538c2ac..35a6085 100644
--- a/Makefile
+++ b/Makefile
@@ -1,3 +1,5 @@
+# Open Infrastructure: compute-tools
+
# Copyright (C) 2014-2021 Daniel Baumann <daniel.baumann@open-infrastructure.net>
#
# SPDX-License-Identifier: GPL-3.0+
diff --git a/VERSION.txt b/VERSION.txt
index 80bc3a6..3b58862 100644
--- a/VERSION.txt
+++ b/VERSION.txt
@@ -1 +1 @@
-20210630
+20210724
diff --git a/libexec/container/stop b/libexec/container/stop
index 58fc0e9..4310a35 100755
--- a/libexec/container/stop
+++ b/libexec/container/stop
@@ -271,6 +271,8 @@ case "${FORCE}" in
do
ip link delete ${VETH} > /dev/null 2>&1 || true
done
+
+ rm -f "${MACHINES}/.#${NAME}.lck"
;;
esac
diff --git a/share/bash-completion/container b/share/bash-completion/container
index d966d7a..2fb49aa 100644
--- a/share/bash-completion/container
+++ b/share/bash-completion/container
@@ -1,5 +1,5 @@
-# bash-completion
-#
+# Open Infrastructure: compute-tools
+
# Copyright (C) 2014-2021 Daniel Baumann <daniel.baumann@open-infrastructure.net>
#
# SPDX-License-Identifier: GPL-3.0+
diff --git a/share/config/container.conf.in b/share/config/container.conf.in
index 3ab014d..d3f9a48 100644
--- a/share/config/container.conf.in
+++ b/share/config/container.conf.in
@@ -1,4 +1,4 @@
-# compute-tools: @NAME@
+# Open Infrastructure: compute-tools
[start]
cnt.auto=@CNT_AUTO@
diff --git a/share/doc/HOST-SETUP.txt b/share/doc/host-setup.txt
index 6b368f0..9a9ec94 100644
--- a/share/doc/HOST-SETUP.txt
+++ b/share/doc/host-setup.txt
@@ -11,27 +11,27 @@ apt install bridge-utils ifenslave vlan
2. Boot Parameters
------------------
-2.1 CGroup Memory Controller
-~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+2.1 CGroup Memory Controller (optional)
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In order to enable the memory controller the following boot parameter needs to be used:
cgroup_enable=memory
-2.2 CGroup Swap Controller
-~~~~~~~~~~~~~~~~~~~~~~~~~~
+2.2 CGroup Swap Controller (optional)
+~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
In order to enable the swap controller the following boot parameter needs to be used:
swapaccount=1
-2.3 vsyscall
-~~~~~~~~~~~~
+2.3 vsyscall (legacy)
+~~~~~~~~~~~~~~~~~~~~~
In order to be able to execute binaries linked to older libc versions
-(<= wheezy) newer linux versions (>= buster), add the following boot parameter
-(see #881813 for more information):
+(<= wheezy) on newer linux versions (>= buster), add the following boot
+parameter (see #881813 for more information):
vsyscall=emulate
@@ -39,18 +39,10 @@ In order to be able to execute binaries linked to older libc versions
3. Networking
~~~~~~~~~~~~~
-3.1 Enable IPv4 Forwarding
-~~~~~~~~~~~~~~~~~~~~~~~~~~
-
-apt install procps
-echo "net.ipv4.ip_forward = 1" > /etc/sysctl.d/ip_foward.conf
-sysctl -p
-
-
-3.2 Configure Network Bridge
+3.1 Configure Network Bridge
~~~~~~~~~~~~~~~~~~~~~~~~~~~~
-3.2.1 Bridge: 1 Interface, standalone, DHCP
+3.1.1 Bridge: 1 Interface, standalone, DHCP
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
cat > /etc/network/interfaces << EOF
@@ -72,7 +64,7 @@ iface bridge0 inet dhcp
EOF
-3.2.2 Bridge: 1 Interface, standalone, static
+3.1.2 Bridge: 1 Interface, standalone, static
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
cat > /etc/network/interfaces << EOF
@@ -101,7 +93,7 @@ iface bridge0 inet static
EOF
-3.2.3 Bridge: 2 logical Interfaces, subnet, static
+3.1.3 Bridge: 2 logical Interfaces, subnet, static
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
cat > /etc/network/interfaces << EOF
@@ -129,7 +121,7 @@ iface bridge0 inet static
EOF
-3.2.4 Bridge: 3 physical Interfaces, vlan, bonding, static
+3.1.4 Bridge: 3 physical Interfaces, vlan, bonding, static
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
cat > /etc/network/interfaces << EOF
diff --git a/share/logrotate/container b/share/logrotate/container
index 0722aa5..d1783de 100644
--- a/share/logrotate/container
+++ b/share/logrotate/container
@@ -1,3 +1,5 @@
+# Open Infrastructure: compute-tools
+
/var/log/compute-tools/container.log {
compress
create 0640 root adm
diff --git a/share/procps/zz-container.conf b/share/procps/zz-container.conf
index c464c42..61c047d 100644
--- a/share/procps/zz-container.conf
+++ b/share/procps/zz-container.conf
@@ -1,3 +1,5 @@
+# Open Infrastructure: compute-tools
+
# The default limits are set to low for running many containers
# and eventually lead to errors like the following on container start:
#
diff --git a/share/scripts/debconf b/share/scripts/debconf
index 9a703e5..86c871f 100755
--- a/share/scripts/debconf
+++ b/share/scripts/debconf
@@ -602,10 +602,14 @@ EOF
IPV4_ADDRESS1_PART4="$(echo ${IPV4_ADDRESS1} | cut -d. -f4)"
IPV6_ADDRESS1="$(${DIG} AAAA +short ${NAME} | tail -n1)"
- # TODO: address parts
+ # FIXME: address parts
+
+ export IPV4_ADDRESS1 IPV4_ADDRESS1_PART1 IPV4_ADDRESS1_PART2 IPV4_ADDRESS1_PART3 IPV4_ADDRESS1_PART4
+ export IPV6_ADDRESS1
fi
- sed -e "s|@NAME@|${NAME}|g" \
+ sed -e "s|@FILE@|${FILE}|g" \
+ -e "s|@NAME@|${NAME}|g" \
-e "s|@IPV4_ADDRESS1@|${IPV4_ADDRESS1}|g" \
-e "s|@IPV4_ADDRESS1_PART1@|${IPV4_ADDRESS1_PART1}|g" \
-e "s|@IPV4_ADDRESS1_PART2@|${IPV4_ADDRESS1_PART2}|g" \
diff --git a/share/scripts/debootstrap b/share/scripts/debootstrap
index f0db7e8..9f5b6eb 100755
--- a/share/scripts/debootstrap
+++ b/share/scripts/debootstrap
@@ -174,9 +174,11 @@ do
fi
done
+# Run
mkdir -p "${MACHINES}"
-
${BOOTSTRAP} ${BOOTSTRAP_OPTIONS} --arch=${ARCHITECTURE} --include=${INCLUDE} ${DISTRIBUTION} ${MACHINES}/${NAME} ${MIRROR}
+
+# Cleaning apt cache
chroot "${MACHINES}/${NAME}" apt clean
# Setting hostname
diff --git a/share/sudo/container-shell b/share/sudo/container-shell
index cd3f74d..c4108a6 100644
--- a/share/sudo/container-shell
+++ b/share/sudo/container-shell
@@ -1 +1,3 @@
+# Open Infrastructure: compute-tools
+
container ALL=NOPASSWD: /usr/bin/container
diff --git a/share/systemd/container-auto.service b/share/systemd/container-auto.service
index 805bdc6..50f8ac6 100644
--- a/share/systemd/container-auto.service
+++ b/share/systemd/container-auto.service
@@ -1,3 +1,5 @@
+# Open Infrastructure: compute-tools
+
[Unit]
Description=compute-tools automatic start and stop
Documentation=man:container-auto
diff --git a/share/systemd/container@.service b/share/systemd/container@.service
index 5d4425e..4bd7be5 100644
--- a/share/systemd/container@.service
+++ b/share/systemd/container@.service
@@ -1,3 +1,5 @@
+# Open Infrastructure: compute-tools
+
[Unit]
Description="Container: %i"
Documentation=man:compute-tools