diff options
author | Daniel Baumann <daniel.baumann@progress-linux.org> | 2022-07-04 13:39:38 +0000 |
---|---|---|
committer | Daniel Baumann <daniel.baumann@progress-linux.org> | 2022-10-02 12:20:18 +0000 |
commit | bff7ee2c0cc8d4f2e087fb3786984f042963240b (patch) | |
tree | f0c5b9df6edd092e64d67c5100b7dcf19d874f16 /Makefile | |
parent | Releasing debian version 20220605-1. (diff) | |
download | open-infrastructure-compute-tools-bff7ee2c0cc8d4f2e087fb3786984f042963240b.tar.xz open-infrastructure-compute-tools-bff7ee2c0cc8d4f2e087fb3786984f042963240b.zip |
Merging upstream version 20220704.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 26 |
1 files changed, 25 insertions, 1 deletions
@@ -25,6 +25,8 @@ PROGRAM = container SCRIPTS = bin/* libexec/*/* +VERSION := $(shell cat VERSION.txt) + all: build test: @@ -226,6 +228,28 @@ clean: rm -f README.txt -distclean: +distclean: clean + rm -rf service-tools-$(VERSION) reinstall: uninstall install + +release: distclean + git commit -a -s -S -m 'Releasing version $(VERSION).' || true + git tag -s -m 'Tagging version $(VERSION).' v$(VERSION) || true + + mkdir -p $(SOFTWARE)-$(VERSION) + find . -mindepth 1 -maxdepth 1 -and -not -name ".git*" -and -not -name debian -and -not -name $(SOFTWARE)-$(VERSION) -exec cp \-a {} $(SOFTWARE)-$(VERSION) \; + + for FORMAT in xz lzip; \ + do \ + EXTENSION=$$(echo $${FORMAT} | cut -b-2); \ + tar --$${FORMAT} -cf ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION} $(SOFTWARE)-$(VERSION); \ + sha512sum ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION} > ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}.sha512; \ + gpg --default-key 0xB62C61A10B93195F --armor -b ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}; \ + mv ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}.asc ../$(SOFTWARE)-$(VERSION).tar.$${EXTENSION}.sig; \ + done + + rm -rf $(SOFTWARE)-$(VERSION) + +upload: + scp ../$(SOFTWARE)-$(VERSION).* get.open-infrastructure.net:/srv/get.open-infrastructure.net/software/$(SOFTWARE)/upstream |