summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2017-04-03 10:25:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2017-04-03 10:25:05 +0000
commit98ba42a446675abeb7fb0780ef9862ccb9ba63ba (patch)
treebee576deafa49f6cad95989ac33d7feebb75d428 /Makefile
parentReleasing debian version 20170101-1. (diff)
downloadopen-infrastructure-compute-tools-98ba42a446675abeb7fb0780ef9862ccb9ba63ba.tar.xz
open-infrastructure-compute-tools-98ba42a446675abeb7fb0780ef9862ccb9ba63ba.zip
Merging upstream version 20170401.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 2 insertions, 8 deletions
diff --git a/Makefile b/Makefile
index 9e6966e..41b6d99 100644
--- a/Makefile
+++ b/Makefile
@@ -118,20 +118,14 @@ uninstall:
for FILE in share/systemd*; \
do \
- if [ -e "$${FILE}" ]; \
- then \
- rm -f $(DESTDIR)/lib/systemd/system/$$(basename $${FILE}); \
- fi; \
+ rm -f $(DESTDIR)/lib/systemd/system/$$(basename $${FILE}); \
done
for SECTION in $$(seq 1 8); \
do \
for FILE in share/man/*.$${SECTION}; \
do \
- if [ -e "$${FILE}" ]; \
- then \
- rm -f $(DESTDIR)/usr/share/man/man$${SECTION}/$$(basename $${FILE}); \
- fi; \
+ rm -f $(DESTDIR)/usr/share/man/man$${SECTION}/$$(basename $${FILE}); \
done; \
rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/usr/share/man/man$${SECTION} || true; \
done