summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-07-25 06:01:17 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-07-25 06:01:17 +0000
commit9676caa0c8ad63964c7b4eb899757aebb9e9aefb (patch)
tree4f32728fc58c3ad154a5e35c44de96a328c46461 /Makefile
parentAdding upstream version 20210724. (diff)
downloadopen-infrastructure-compute-tools-9676caa0c8ad63964c7b4eb899757aebb9e9aefb.tar.xz
open-infrastructure-compute-tools-9676caa0c8ad63964c7b4eb899757aebb9e9aefb.zip
Adding upstream version 20210725.upstream/20210725
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile b/Makefile
index 35a6085..0cb6291 100644
--- a/Makefile
+++ b/Makefile
@@ -51,7 +51,7 @@ test:
# FIXME: fail hard on shellcheck once all issues are fixed
@echo -n "Checking with shellcheck... "
- @if [ -x /usr/bin/checkbashisms ]; \
+ @if [ -x /usr/bin/shellcheck ]; \
then \
for SCRIPT in $(SCRIPTS); \
do \
@@ -63,10 +63,10 @@ test:
fi
@echo " done."
-build: share/man/*.txt
+build: share/man/*.rst
$(MAKE) -C share/man
- sed -n '/^NAME/,$$p' share/man/$(SOFTWARE).7.txt > README.txt
+ sed -n '/^===/,$$p' share/man/$(SOFTWARE).7.rst > README.txt
install: build
mkdir -p $(DESTDIR)/etc/$(SOFTWARE)/config