summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2016-10-25 13:10:17 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2016-10-25 13:10:17 +0000
commit17e90600218e654071457f0845968e143e8c5d15 (patch)
treef58c502fe6dadaef45e1a3844944905837b37e51 /Makefile
parentAdding upstream version 20160801. (diff)
downloadopen-infrastructure-compute-tools-17e90600218e654071457f0845968e143e8c5d15.tar.xz
open-infrastructure-compute-tools-17e90600218e654071457f0845968e143e8c5d15.zip
Adding upstream version 20161101.upstream/20161101
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index e61c559..94289f2 100644
--- a/Makefile
+++ b/Makefile
@@ -69,7 +69,11 @@ install: build
mkdir -p $(DESTDIR)/usr/share/bash-completion/completions
cp -r share/bash-completion/* $(DESTDIR)/usr/share/bash-completion/completions
- mkdir -p $(DESTDIR)/usr/share/doc/$(SOFTWARE)
+ mkdir -p $(DESTDIR)/etc/sudoers.d
+ cp -r share/sudo/* $(DESTDIR)/etc/sudoers.d
+ chmod 0440 $(DESTDIR)/etc/sudoers.d/*
+
+ mkdir -p $(DESTDIR)/usr/share/doc
cp -r share/doc $(DESTDIR)/usr/share/doc/$(SOFTWARE)
for SECTION in $$(seq 1 8); \
@@ -124,6 +128,11 @@ uninstall:
rm -f $(DESTDIR)/usr/share/man/man1/cntsh.1
rm -f ${DESTDIR}/usr/share/bash-completion/completions/cnt
+ for FILE in share/sudo/*; \
+ do \
+ rm -f $(DESTDIR)/etc/sudoers.d/$$(basename $${FILE}); \
+ done
+
for FILE in share/bash-completion/*; \
do \
rm -f $(DESTDIR)/usr/share/bash-completion/completions/$$(basename $${FILE}); \