summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-09-20 13:18:09 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-09-20 13:18:09 +0000
commitf5c2d5b90dde7d6b1cfc6abc2756ad8ea9f54c1a (patch)
treee9cf08ef667bf2aa99e2a93486dbb2445bf875e1
parentAdding upstream version 20221227. (diff)
downloadopen-infrastructure-service-tools-f5c2d5b90dde7d6b1cfc6abc2756ad8ea9f54c1a.tar.xz
open-infrastructure-service-tools-f5c2d5b90dde7d6b1cfc6abc2756ad8ea9f54c1a.zip
Adding upstream version 20221228.upstream/20221228
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--CHANGELOG.txt7
-rw-r--r--VERSION.txt2
-rwxr-xr-xdehydrated/share/hooks/deploy_ocsp.extra2
-rw-r--r--supermicro/Makefile80
-rwxr-xr-xsupermicro/bin/supermicro-ipmi-reset28
5 files changed, 117 insertions, 2 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index bbfc06f..52293ed 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,3 +1,10 @@
+2022-12-28 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+
+ * Releasing version 20221228.
+
+ [ Daniel Baumann ]
+ * Adding supermicro tools.
+
2022-12-27 Daniel Baumann <daniel.baumann@open-infrastructure.net>
* Releasing version 20221227.
diff --git a/VERSION.txt b/VERSION.txt
index 154fbb1..e65d79f 100644
--- a/VERSION.txt
+++ b/VERSION.txt
@@ -1 +1 @@
-20221227
+20221228
diff --git a/dehydrated/share/hooks/deploy_ocsp.extra b/dehydrated/share/hooks/deploy_ocsp.extra
index 92b2247..8874f79 100755
--- a/dehydrated/share/hooks/deploy_ocsp.extra
+++ b/dehydrated/share/hooks/deploy_ocsp.extra
@@ -30,7 +30,7 @@ for EXTRA in fullchain_privkey privkey_fullchain root_intermediate_cert
do
rm -f "${DIRECTORY}/${EXTRA}-${TIMESTAMP}.pem.ocsp"
- ln -sf "${OCSPFILE}" "${DIRECTORY}/${EXTRA}.pem.ocsp"
+ ln -sf "${OCSP}" "${DIRECTORY}/${EXTRA}.pem.ocsp"
done
echo " done."
diff --git a/supermicro/Makefile b/supermicro/Makefile
new file mode 100644
index 0000000..6b3744b
--- /dev/null
+++ b/supermicro/Makefile
@@ -0,0 +1,80 @@
+# Open Infrastructure: service-tools
+
+# Copyright (C) 2014-2022 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+SHELL := sh -e
+
+SCRIPTS = bin/*
+
+all: build
+
+test:
+ @echo -n "Checking for syntax errors with sh... "
+ @for SCRIPT in $(SCRIPTS); \
+ do \
+ sh -n $${SCRIPT}; \
+ echo -n "."; \
+ done
+ @echo " done."
+
+ @echo -n "Checking for bashisms... "
+ @if [ -x /usr/bin/checkbashisms ]; \
+ then \
+ for SCRIPT in $(SCRIPTS); \
+ do \
+ checkbashisms -f -x $${SCRIPT}; \
+ echo -n "."; \
+ done; \
+ else \
+ echo "Note: devscripts not installed, skipping checkbashisms."; \
+ fi
+ @echo " done."
+
+ @echo -n "Checking with shellcheck... "
+ @if [ -x /usr/bin/shellcheck ]; \
+ then \
+ for SCRIPT in $(SCRIPTS); \
+ do \
+ shellcheck -e SC2039 $${SCRIPT}; \
+ echo -n "."; \
+ done; \
+ else \
+ echo "Note: shellcheck not installed, skipping shellcheck."; \
+ fi
+ @echo " done."
+
+build:
+
+install: build
+ mkdir -p $(DESTDIR)/usr/bin
+ cp -r bin/* $(DESTDIR)/usr/bin
+
+uninstall:
+ for FILE in bin/*; \
+ do \
+ rm -f $(DESTDIR)/usr/bin/$$(basename $${FILE}); \
+ done
+ rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/usr/bin || true
+
+ rmdir --ignore-fail-on-non-empty --parents $(DESTDIR) || true
+
+clean:
+
+distclean:
+
+reinstall: uninstall install
diff --git a/supermicro/bin/supermicro-ipmi-reset b/supermicro/bin/supermicro-ipmi-reset
new file mode 100755
index 0000000..6b6e11a
--- /dev/null
+++ b/supermicro/bin/supermicro-ipmi-reset
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+set -e
+
+PROGRAM="$(basename "${0}")"
+
+HOST="$(sed -e 's|.host$|.management|' /etc/hostname)"
+ADDRESS="$(ipcalc-ng --all-info "$(dig +short AAAA "${HOST}")" | awk '/^Full Address/ { print $3 }')"
+
+if [ -z "${ADDRESS}" ]
+then
+ "${PROGRAM}: no IP address found for ${HOST}"
+ exit 1
+fi
+
+echo "${PROGRAM}: resetting ipmi to factory defaults (including users and lan)"
+ipmicfg -fdl -d
+
+echo "${PROGRAM}: disabling ipv4 dhcp for ipv6-only configuration"
+ipmicfg -dhcp off
+
+echo "${PROGRAM}: configuring ipmi to ${ADDRESS}"
+ipmicfg -ipv6 add 1 "${ADDRESS}" 64
+
+echo "${PROGRAM}: rebooting ipmi"
+ipmicfg -r -d
+
+echo "${PROGRAM}: done."