summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2017-04-11 06:16:20 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2017-07-01 08:13:45 +0000
commit4f1b0d6f3a035f8e367d84a4fae0593ad85068e9 (patch)
treeda552e03a39d9f7037e67624b3edacc11b1ed567
parentRemoving superfluous --parallel when invoking debhelper as it's the default w... (diff)
downloadopen-infrastructure-service-tools-4f1b0d6f3a035f8e367d84a4fae0593ad85068e9.tar.xz
open-infrastructure-service-tools-4f1b0d6f3a035f8e367d84a4fae0593ad85068e9.zip
Generalizing rules file.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rwxr-xr-xdebian/rules10
1 files changed, 10 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
index 18a14f6..63dcdd4 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,17 @@
#!/usr/bin/make -f
+PACKAGE := apache-icons
+
%:
dh ${@} --with apache2
override_dh_auto_build:
# disabled
+
+override_dh_auto_install:
+ dh_auto_install
+
+ rm -f debian/open-infrastructure-$(PACKAGE)/usr/share/doc/$(PACKAGE)/CHANGELOG.txt
+ rm -f debian/open-infrastructure-$(PACKAGE)/usr/share/doc/$(PACKAGE)/LICENSE.txt
+
+ mv debian/open-infrastructure-$(PACKAGE)/usr/share/doc/$(PACKAGE) debian/open-infrastructure-$(PACKAGE)/usr/share/doc/open-infrastructure-$(PACKAGE)