summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-13 13:45:16 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-12-13 13:45:25 +0000
commite5f2697c7126cc65ff494279e616541fe8fda0b4 (patch)
tree3954e74d572b1d2bcc43a1d6f967fb212996af17
parentReleasing debian version 20210928-1. (diff)
downloadopen-infrastructure-service-tools-e5f2697c7126cc65ff494279e616541fe8fda0b4.tar.xz
open-infrastructure-service-tools-e5f2697c7126cc65ff494279e616541fe8fda0b4.zip
Merging upstream version 20211213.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--CHANGELOG.txt8
-rw-r--r--VERSION.txt2
-rwxr-xr-xgit/bin/git-checkout-branches7
-rw-r--r--vim/Makefile80
-rwxr-xr-xvim/bin/vim-mtime34
5 files changed, 124 insertions, 7 deletions
diff --git a/CHANGELOG.txt b/CHANGELOG.txt
index cf850f3..5b2fd5c 100644
--- a/CHANGELOG.txt
+++ b/CHANGELOG.txt
@@ -1,3 +1,11 @@
+2021-12-13 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+
+ * Releasing version 20211213.
+
+ [ Daniel Baumann ]
+ * Correcting current and default branch handling in git-checkout-branches.
+ * Adding vim-tools.
+
2021-09-28 Daniel Baumann <daniel.baumann@open-infrastructure.net>
* Releasing version 20210928.
diff --git a/VERSION.txt b/VERSION.txt
index fbdb929..6fc1d23 100644
--- a/VERSION.txt
+++ b/VERSION.txt
@@ -1 +1 @@
-20210928
+20211213
diff --git a/git/bin/git-checkout-branches b/git/bin/git-checkout-branches
index f1aa862..e98345d 100755
--- a/git/bin/git-checkout-branches
+++ b/git/bin/git-checkout-branches
@@ -29,16 +29,11 @@ do
BRANCH="$(echo "${REMOTE_BRANCH}" | cut -d/ -f 2-)"
case "${BRANCH}" in
- HEAD)
+ HEAD|${CURRENT_BRANCH})
continue
;;
esac
- if git branch | grep -Eq "^ *${BRANCH}$"
- then
- continue
- fi
-
git checkout -b "${BRANCH}" "${REMOTE_BRANCH}"
done
diff --git a/vim/Makefile b/vim/Makefile
new file mode 100644
index 0000000..3a2e4b9
--- /dev/null
+++ b/vim/Makefile
@@ -0,0 +1,80 @@
+# Open Infrastructure: service-tools
+
+# Copyright (C) 2014-2021 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+SHELL := sh -e
+
+SCRIPTS = bin/*
+
+all: build
+
+test:
+ @echo -n "Checking for syntax errors with sh... "
+ @for SCRIPT in $(SCRIPTS); \
+ do \
+ sh -n $${SCRIPT}; \
+ echo -n "."; \
+ done
+ @echo " done."
+
+ @echo -n "Checking for bashisms... "
+ @if [ -x /usr/bin/checkbashisms ]; \
+ then \
+ for SCRIPT in $(SCRIPTS); \
+ do \
+ checkbashisms -f -x $${SCRIPT}; \
+ echo -n "."; \
+ done; \
+ else \
+ echo "Note: devscripts not installed, skipping checkbashisms."; \
+ fi
+ @echo " done."
+
+ @echo -n "Checking with shellcheck... "
+ @if [ -x /usr/bin/shellcheck ]; \
+ then \
+ for SCRIPT in $(SCRIPTS); \
+ do \
+ shellcheck -e SC2039 $${SCRIPT}; \
+ echo -n "."; \
+ done; \
+ else \
+ echo "Note: shellcheck not installed, skipping shellcheck."; \
+ fi
+ @echo " done."
+
+build:
+
+install: build
+ mkdir -p $(DESTDIR)/usr/bin
+ cp -r bin/* $(DESTDIR)/usr/bin
+
+uninstall:
+ for FILE in bin/*; \
+ do \
+ rm -f $(DESTDIR)/usr/bin/$$(basename $${FILE}); \
+ done
+ rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/usr/bin || true
+
+ rmdir --ignore-fail-on-non-empty --parents $(DESTDIR) || true
+
+clean:
+
+distclean:
+
+reinstall: uninstall install
diff --git a/vim/bin/vim-mtime b/vim/bin/vim-mtime
new file mode 100755
index 0000000..d04e8ee
--- /dev/null
+++ b/vim/bin/vim-mtime
@@ -0,0 +1,34 @@
+#!/bin/sh
+
+# Open Infrastructure: service-tools
+
+# Copyright (C) 2014-2021 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+#
+# SPDX-License-Identifier: GPL-3.0+
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <https://www.gnu.org/licenses/>.
+
+set -e
+
+for FILE in "${@}"
+do
+ TMPFILE="$(tmpfile vi-mtime.XXXX)"
+
+ touch -r "${FILE}" "${TMPFILE}"
+
+ vi "${FILE}"
+
+ touch -r "${TMPFILE}" "${FILE}"
+ rm -f "${TMPFILE}"
+done