summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-06-16 21:58:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-06-16 21:58:37 +0000
commitf34d61150ee6777206a58481efedd69c8e7966ef (patch)
tree68e3e0a382562e886ab2b5249add13949d9ad15f /Makefile
parentAdding upstream version 20220614. (diff)
downloadopen-infrastructure-service-tools-f34d61150ee6777206a58481efedd69c8e7966ef.tar.xz
open-infrastructure-service-tools-f34d61150ee6777206a58481efedd69c8e7966ef.zip
Adding upstream version 20220615.upstream/20220615
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 3c55809..a9a2be1 100644
--- a/Makefile
+++ b/Makefile
@@ -77,6 +77,9 @@ distclean:
reinstall: uninstall install
release: distclean
+ git commit -a -s -S -m 'Releasing version $(VERSION).' || true
+ git tag -s -m 'Tagging version $(VERSION).' v$(VERSION) || true
+
mkdir service-tools-$(VERSION)
find . -mindepth 1 -maxdepth 1 -and -not -name ".git*" -and -not -name debian -and -not -name service-tools-$(VERSION) -exec cp \-a {} service-tools-$(VERSION) \;