summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2022-11-15 12:32:33 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2022-11-15 14:51:56 +0000
commitf255c48c5a2bba0d4bc17489b849cf78695a3b43 (patch)
tree339a7977c143487def589a8fe2a3951577e2aa71 /debian/rules
parentReleasing debian version 20221108-1. (diff)
downloadopen-infrastructure-service-tools-f255c48c5a2bba0d4bc17489b849cf78695a3b43.tar.xz
open-infrastructure-service-tools-f255c48c5a2bba0d4bc17489b849cf78695a3b43.zip
Renaming apache-tools package to service-tools to avoid future micro-packaging by using one consistent name for the binary package.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-xdebian/rules20
1 files changed, 5 insertions, 15 deletions
diff --git a/debian/rules b/debian/rules
index b3924c0..62c4dda 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,23 +1,13 @@
#!/usr/bin/make -f
-PACKAGES := $(shell dh_listpackages | cut -d '-' -f 3- | sed -e 's|-tools$$||')
-
%:
dh ${@} --with apache2
override_dh_auto_install:
- for PACKAGE in $(PACKAGES); \
- do \
- $(MAKE) -C $${PACKAGE} DESTDIR=$(CURDIR)/debian/open-infrastructure-$${PACKAGE}-tools install; \
- done
-
# apache-tools
- rm -f debian/open-infrastructure-apache-tools/usr/share/doc/apache-tools/CHANGELOG.txt
- rm -f debian/open-infrastructure-apache-tools/usr/share/doc/apache-tools/LICENSE.txt
- -mv debian/open-infrastructure-apache-tools/usr/share/doc/* debian/open-infrastructure-apache-tools/usr/share/doc/open-infrastructure-apache-tools
+ $(MAKE) -C apache DESTDIR=$(CURDIR)/debian/open-infrastructure-service-tools install
-ifeq (open-infrastructure-linux-tools,$(findstring open-infrastructure-linux-tools,$(PACKAGES)))
-override_dh_installsystemd:
- dh_installsystemd -p open-infrastructure-linux-tools --no-restart-after-upgrade --no-start --no-stop-on-upgrade
- dh_installsystemd --remaining-packages
-endif
+ # service-tools
+ rm -f debian/open-infrastructure-service-tools/usr/share/doc/service-tools/CHANGELOG.txt
+ rm -f debian/open-infrastructure-service-tools/usr/share/doc/service-tools/LICENSE.txt
+ -mv debian/open-infrastructure-service-tools/usr/share/doc/* debian/open-infrastructure-service-tools/usr/share/doc/open-infrastructure-service-tools