summaryrefslogtreecommitdiffstats
path: root/knot/Makefile
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-09-06 05:24:37 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-09-06 05:24:37 +0000
commita2d154a429d225e29038ceef6ae4022854096c2e (patch)
tree1c01675a68f3040bb7f1df61e9c57479483effe8 /knot/Makefile
parentReleasing debian version 20210905-1. (diff)
downloadopen-infrastructure-service-tools-a2d154a429d225e29038ceef6ae4022854096c2e.tar.xz
open-infrastructure-service-tools-a2d154a429d225e29038ceef6ae4022854096c2e.zip
Merging upstream version 20210906.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'knot/Makefile')
-rw-r--r--knot/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/knot/Makefile b/knot/Makefile
index 3a2e4b9..9b3ef3b 100644
--- a/knot/Makefile
+++ b/knot/Makefile
@@ -61,6 +61,9 @@ test:
build:
install: build
+ mkdir -p $(DESTDIR)/etc/cron.d
+ cp -r share/cron/* $(DESTDIR)/etc/cron.d
+
mkdir -p $(DESTDIR)/usr/bin
cp -r bin/* $(DESTDIR)/usr/bin
@@ -71,6 +74,12 @@ uninstall:
done
rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/usr/bin || true
+ for FILE in share/cron/*; \
+ do \
+ rm -f $(DESTDIR)/etc/cron.d/$$(basename $${FILE}); \
+ done
+ rmdir --ignore-fail-on-non-empty --parents $(DESTDIR)/etc/cron.d || true
+
rmdir --ignore-fail-on-non-empty --parents $(DESTDIR) || true
clean: