summaryrefslogtreecommitdiffstats
path: root/linux/share/man/Makefile
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--[-rwxr-xr-x]linux/share/man/Makefile (renamed from ethtool/bin/ethtool-i40e)52
1 files changed, 37 insertions, 15 deletions
diff --git a/ethtool/bin/ethtool-i40e b/linux/share/man/Makefile
index 637ae65..a6d6bf2 100755..100644
--- a/ethtool/bin/ethtool-i40e
+++ b/linux/share/man/Makefile
@@ -1,5 +1,3 @@
-#!/bin/sh
-
# Open Infrastructure: service-tools
# Copyright (C) 2014-2022 Daniel Baumann <daniel.baumann@open-infrastructure.net>
@@ -19,19 +17,43 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <https://www.gnu.org/licenses/>.
-set -e
+# Depends: python3-docutils
+
+RST2MAN = rst2man \
+ --no-datestamp \
+ --no-generator \
+ --strict \
+ --strip-comments \
+ --tab-width=4 \
+ --verbose
+
+VERSION := $(shell cat ../../../VERSION.txt)
+
+SHELL := sh -e
+
+all: build
+
+build: man
+
+man: man.in *.rst
+ @echo -n "Creating manpages... "
+
+ @for FILE in *.rst; \
+ do \
+ cp man.in $$(basename $${FILE} .rst); \
+ $(RST2MAN) $${FILE} | \
+ sed -e '/^.\\" Man page generated/d' \
+ -e '/^.\\" Generated by/d' \
+ -e "s|^\(.TH .*\) \(\"\" \"\"\) |\1 $${VERSION} service-tools |" \
+ >> $$(basename $${FILE} .rst); \
+ echo -n "."; \
+ done
+
+ @echo " done."
-PROGRAM="$(basename ${0})"
-DEVICES="$(grep DRIVER=i40e /sys/class/net/*/device/uevent | awk -F/ '{ print $5 }' | sort -V)"
+clean:
+ rm -f *.[0-9]
-if [ -z "${DEVICES}" ]
-then
- echo "'${PROGRAM}': no network devices available with i40e driver"
-fi
+distclean: clean
-for DEVICE in ${DEVICES}
-do
- echo -n "'${DEVICE}': disabling FW LLDP..."
- ethtool --set-priv-flags ${DEVICE} disable-fw-lldp on
- echo " done."
-done
+rebuild: clean build