summaryrefslogtreecommitdiffstats
path: root/share/man
diff options
context:
space:
mode:
Diffstat (limited to 'share/man')
-rw-r--r--share/man/Makefile43
-rw-r--r--share/man/ceph-info.1.txt93
-rw-r--r--share/man/ceph-log.1.txt88
-rw-r--r--share/man/ceph-remove-osd.1.txt64
-rw-r--r--share/man/cephfs-snap.1.txt72
-rw-r--r--share/man/storage-tools.7.txt91
6 files changed, 451 insertions, 0 deletions
diff --git a/share/man/Makefile b/share/man/Makefile
new file mode 100644
index 0000000..03b5914
--- /dev/null
+++ b/share/man/Makefile
@@ -0,0 +1,43 @@
+# Makefile
+
+# storage-tools - Additional utilities to manage storage related tasks
+# Copyright (C) 2014-2017 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+# Depends: asciidoc dblatex docbook-xsl libxml2-utils source-highlight
+
+A2X = a2x \
+ --asciidoc-opts "-a revdate=$(shell cat ../../VERSION.txt)" \
+ --doctype=manpage
+
+SHELL := sh -e
+
+all: build
+
+clean:
+ rm -f *.[0-9]
+ rm -f *.xml
+
+build: man
+
+rebuild: clean build
+
+man: *.txt
+ for FILE in *.txt; \
+ do \
+ $(A2X) --format=manpage $${FILE}; \
+ done
+
+.PHONY: all clean build rebuild man
diff --git a/share/man/ceph-info.1.txt b/share/man/ceph-info.1.txt
new file mode 100644
index 0000000..72c50b1
--- /dev/null
+++ b/share/man/ceph-info.1.txt
@@ -0,0 +1,93 @@
+// storage-tools - Additional utilities to manage storage related tasks
+// Copyright (C) 2014-2017 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+//
+// This program is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// This program is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+CEPH-INFO(1)
+============
+:doctype: manpage
+:man manual: Open Infrastructure
+:man source: storage-tools
+:man version: {revnumber}
+
+
+NAME
+----
+ceph-info - show Ceph cluster information as a website.
+
+
+SYNOPSIS
+--------
+*ceph-info*
+
+
+DESCRIPTION
+-----------
+When operating large, central storage systems the trust of the users that their
+data is always safe is paramount. Specifically in the enterprise environment,
+gaining trust from the users to save their data on your Ceph cluster (which
+is "just" SDS) can be achieved with technical transparency.
+
+The ceph-info program shows Ceph cluster information as a website where anyone
+interested can observe the clusters health and action transparently, without
+requireing Ceph specific knowledge or access privileges.
+
+For the system administrators it provides a neat "one page" overview of all
+essential health information of the cluster, rather than to do the same commands
+over the command line.
+
+The info page is by default visible on http://localhost/ceph-info
+
+
+OPTIONS
+-------
+The ceph-info program has no options.
+
+
+FILES
+-----
+The following files are used:
+
+*/etc/default/storage-tools*::
+ Configuration file.
+
+*/var/log/storage-tools/ceph-info/*.txt*::
+ Ceph cluster information dumps.
+
+*/usr/share/storage-tools/ceph-info/web*::
+ ceph-info document root.
+
+
+SEE ALSO
+--------
+storage-tools(7).
+
+
+HOMEPAGE
+--------
+More information about storage-tools and the Open Infrastructure project can be
+found on the homepage at https://open-infrastructure.net.
+
+
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
+
+
+AUTHORS
+-------
+storage-tools was written by Daniel Baumann <daniel.baumann@open-infrastructure.net>.
diff --git a/share/man/ceph-log.1.txt b/share/man/ceph-log.1.txt
new file mode 100644
index 0000000..c3fe237
--- /dev/null
+++ b/share/man/ceph-log.1.txt
@@ -0,0 +1,88 @@
+// storage-tools - Additional utilities to manage storage related tasks
+// Copyright (C) 2014-2017 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+//
+// This program is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// This program is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+CEPH-LOG(1)
+===========
+:doctype: manpage
+:man manual: Open Infrastructure
+:man source: storage-tools
+:man version: {revnumber}
+
+
+NAME
+----
+ceph-log - store Ceph cluster log as a logfile
+
+
+SYNOPSIS
+--------
+*ceph-log*
+
+
+DESCRIPTION
+-----------
+When operating a Ceph storage cluster, the command 'ceph -w' let's the system
+administrator watch everything that is happening in a ceph cluster, such as the
+health state of the cluster, any cluster changes and any commands and mounts
+from clients that are happening.
+
+Unfortunatly the 'ceph -w' command is a tool that a system administrator uses
+for real time information, means there is no history or looking backward what
+happened at a given time.
+
+The ceph-log program stores the output of 'ceph -w' into a logfile and rotate
+its. This allows the system administrator to go back and check what exactly
+happened in detail within a Ceph storage cluster at any given time.
+
+
+OPTIONS
+-------
+The ceph-log program has no options.
+
+
+FILES
+-----
+The following files are used:
+
+*/etc/default/storage-tools*::
+ Configuration file.
+
+*/var/log/storage-tools/ceph-log/ceph-watch.log*::
+ Ceph cluster logfile.
+
+
+SEE ALSO
+--------
+storage-tools(7).
+
+
+HOMEPAGE
+--------
+More information about storage-tools and the Open Infrastructure project can be
+found on the homepage at https://open-infrastructure.net.
+
+
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
+
+
+AUTHORS
+-------
+storage-tools was written by Daniel Baumann <daniel.baumann@open-infrastructure.net>.
diff --git a/share/man/ceph-remove-osd.1.txt b/share/man/ceph-remove-osd.1.txt
new file mode 100644
index 0000000..28b6062
--- /dev/null
+++ b/share/man/ceph-remove-osd.1.txt
@@ -0,0 +1,64 @@
+// storage-tools - Additional utilities to manage storage related tasks
+// Copyright (C) 2014-2017 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+//
+// This program is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// This program is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+CEPH-REMOVE-OSD(1)
+==================
+:doctype: manpage
+:man manual: Open Infrastructure
+:man source: storage-tools
+:man version: {revnumber}
+
+
+NAME
+----
+ceph-remove-osd - shortcut for removing an Ceph OSD instance completly.
+
+
+SYNOPSIS
+--------
+*ceph-remove-osd* OSD
+
+
+DESCRIPTION
+-----------
+When replacing a broken disk in a Ceph storage cluster, the correct OSD
+needs to be shut down properly and its keys removed.
+
+ceph-remove-osd does all required steps.
+
+
+SEE ALSO
+--------
+storage-tools(7).
+
+
+HOMEPAGE
+--------
+More information about storage-tools and the Open Infrastructure project can be
+found on the homepage at https://open-infrastructure.net.
+
+
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
+
+
+AUTHORS
+-------
+storage-tools was written by Daniel Baumann <daniel.baumann@open-infrastructure.net>.
diff --git a/share/man/cephfs-snap.1.txt b/share/man/cephfs-snap.1.txt
new file mode 100644
index 0000000..972bcd0
--- /dev/null
+++ b/share/man/cephfs-snap.1.txt
@@ -0,0 +1,72 @@
+// storage-tools - Additional utilities to manage storage related tasks
+// Copyright (C) 2014-2017 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+//
+// This program is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// This program is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+CEPHFS-SNAP(1)
+==============
+:doctype: manpage
+:man manual: Open Infrastructure
+:man source: storage-tools
+:man version: {revnumber}
+
+
+NAME
+----
+cephfs-snap - create CephFS snapshots periodically
+
+
+SYNOPSIS
+--------
+*cephfs-snap* {hourly|daily|weekly|monthly}
+
+
+DESCRIPTION
+-----------
+CephFS supports creating snapshots of the filesystem as a simple means of
+backups.
+
+The cephfs-snap program is a simple tool to do this periodically.
+
+
+FILES
+-----
+The following files are used:
+
+*/etc/default/storage-tools*::
+ Configuration file.
+
+
+SEE ALSO
+--------
+storage-tools(7).
+
+
+HOMEPAGE
+--------
+More information about storage-tools and the Open Infrastructure project can be
+found on the homepage at https://open-infrastructure.net.
+
+
+CONTACT
+-------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List <software@lists.open-infrastructure.net>.
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System at https://bugs.debian.org.
+
+
+AUTHORS
+-------
+storage-tools was written by Daniel Baumann <daniel.baumann@open-infrastructure.net>.
diff --git a/share/man/storage-tools.7.txt b/share/man/storage-tools.7.txt
new file mode 100644
index 0000000..20bae0b
--- /dev/null
+++ b/share/man/storage-tools.7.txt
@@ -0,0 +1,91 @@
+// storage-tools - Additional utilities to manage storage related tasks
+// Copyright (C) 2014-2017 Daniel Baumann <daniel.baumann@open-infrastructure.net>
+//
+// This program is free software: you can redistribute it and/or modify
+// it under the terms of the GNU General Public License as published by
+// the Free Software Foundation, either version 3 of the License, or
+// (at your option) any later version.
+//
+// This program is distributed in the hope that it will be useful,
+// but WITHOUT ANY WARRANTY; without even the implied warranty of
+// MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+// GNU General Public License for more details.
+//
+// You should have received a copy of the GNU General Public License
+// along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+STORAGE-TOOLS(7)
+================
+:doctype: manpage
+:man manual: Open Infrastructure
+:man source: storage-tools
+:man version: {revnumber}
+
+
+NAME
+----
+storage-tools - Additional utilities to manage storage related tasks
+
+
+DESCRIPTION
+-----------
+"Computer data storage [...] is a technology consisting of computer components
+and recording media used to retain digital data. It is a core function and
+fundamental component of computers."
+ -- Wikipedia (https://en.wikipedia.org/wiki/Data_storage_device)
+
+storage-tools contains additional utilities to manage storage related tasks.
+
+
+DOWNLOAD
+--------
+ * Upstream Releases: https://files.open-infrastructure.net/software/storage-tools/upstream
+ * Upstream Sources: https://sources.open-infrastructure.net/software/storage-tools
+ * Debian Releases: https://files.open-infrastructure.net/software/storage-tools/debian
+ * Debian Sources: https://sources.progress-linux.org/users/daniel/debian/packages/open-infrastructure-storage-tools
+
+
+INSTALLATION
+------------
+
+SOURCE
+~~~~~~
+ 1. sudo apt install asciidoc git docbook-xml docbook-xsl libxml2-utils make xsltproc
+ 2. git clone https://sources.open-infrastructure.net/software/storage-tools
+ 3. cd storage-tools && sudo make install
+
+
+DEVELOPMENT
+-----------
+Bug reports, feature requests, help, patches, support and everything else
+are welcome on the Open Infrastructure Software Mailing List:
+
+ * https://lists.open-infrastructure.net/listinfo/software
+
+Please base patches against the 'next' Git branch using common sense:
+
+ * https://www.kernel.org/doc/Documentation/SubmittingPatches
+
+Debian specific bugs can also be reported in the Debian Bug Tracking System:
+
+ * https://bugs.debian.org
+
+
+TOOLS
+-----
+*ceph-log(1):*::
+ store Ceph cluster log as a logfile.
+
+*ceph-info(1):*::
+ show Ceph cluster information as a website.
+
+*cephfs-snap(1):*::
+ create CephFS snapshots periodically.
+
+*ceph-remove-osd(1):*::
+ shortcut for removing an Ceph OSD instance completly.
+
+
+AUTHORS
+-------
+ * Daniel Baumann <daniel.baumann@open-infrastructure.net>