summaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2019-02-02 10:12:36 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2019-02-02 10:38:49 +0000
commit9bd164541265dc60b94627467b2953ae36e6b944 (patch)
treeefb432955dab2e69fb1a9601eeb0bd3c03d1a2ab /debian/rules
parentAdding upstream version 20190202. (diff)
downloadopen-infrastructure-system-tools-9bd164541265dc60b94627467b2953ae36e6b944.tar.xz
open-infrastructure-system-tools-9bd164541265dc60b94627467b2953ae36e6b944.zip
Adding debian version 20190202-1.debian/20190202-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules72
1 files changed, 72 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..40bb80f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,72 @@
+#!/usr/bin/make -f
+
+%:
+ dh ${@}
+
+override_dh_auto_clean:
+ dh_auto_clean
+
+ $(MAKE) -C system-boot clean
+ $(MAKE) -C system-build clean
+ $(MAKE) -C system-config clean
+ $(MAKE) -C system-images clean
+
+override_dh_auto_build:
+ dh_auto_build
+
+ $(MAKE) -C system-boot
+ $(MAKE) -C system-build
+ $(MAKE) -C system-config
+ $(MAKE) -C system-images
+
+override_dh_auto_install:
+ dh_auto_install
+
+ $(MAKE) -C system-boot install DESTDIR=$(CURDIR)/debian/open-infrastructure-system-boot
+ $(MAKE) -C system-build install DESTDIR=$(CURDIR)/debian/open-infrastructure-system-build
+ $(MAKE) -C system-config install DESTDIR=$(CURDIR)/debian/open-infrastructure-system-config
+ $(MAKE) -C system-images install DESTDIR=$(CURDIR)/debian/open-infrastructure-system-images
+
+ # Removing useless files
+ rm -rf debian/*/usr/share/doc/live-boot
+ rm -f debian/*/bin/live-swapfile
+
+ rm -rf debian/*/usr/share/doc/live-build
+
+ rm -f debian/open-infrastructure-system-images/usr/share/doc/system-images/CHANGELOG.txt
+ rm -f debian/open-infrastructure-system-images/usr/share/doc/system-images/LICENSE.txt
+ mv debian/open-infrastructure-system-images/usr/share/doc/system-images debian/open-infrastructure-system-images/usr/share/doc/open-infrastructure-system-images
+
+override_dh_compress:
+ dh_compress -Xusr/share/doc/open-infrastructure-system-config/examples -Xusr/share/system-images
+
+ # Recompressing without timestamp
+ cd debian/open-infrastructure-system-build/usr/share/live/build/bootloaders/grub-legacy && \
+ gunzip splash.xpm.gz && \
+ gzip -n splash.xpm
+
+ # Using systemd instead of sysvinit
+ rm -rf debian/*/etc/init.d
+ rm -f debian/*/lib/live/config/*-sysvinit
+ rm -f debian/*/lib/live/config/*-sysv-rc
+
+ # Using user-setup instead of live-debconfig
+ rm -f debian/tmp/live/config/*live-debconfig*
+
+ # Removing unused files
+ rm -rf debian/*/usr/share/doc/live-config
+ rm -f debian/*/bin/live-config-update
+
+override_dh_link:
+ dh_link
+
+ # workaround dh_link convertion of absolute symlinks to relvative symlinks
+ rm -rf debian/open-infrastructure-system-build/usr/share/live/build/bootloaders
+ cp -a system-build/share/bootloaders debian/open-infrastructure-system-build/usr/share/live/build/bootloaders
+
+ for DIRECTORY in debian/*/usr/share/system-images/*; \
+ do \
+ IMAGE="$$(basename $${DIRECTORY})"; \
+ rm -rf debian/open-infrastructure-system-images/usr/share/system-images/$${IMAGE}/config/bootloaders; \
+ cp -a system-images/share/images/$${IMAGE}/config/bootloaders debian/open-infrastructure-system-images/usr/share/system-images/$${IMAGE}/config/bootloaders; \
+ done