summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog9
-rw-r--r--debian/control114
-rw-r--r--debian/copyright32
-rwxr-xr-xdebian/open-infrastructure-system-boot.postinst27
-rwxr-xr-xdebian/open-infrastructure-system-boot.postrm28
-rw-r--r--debian/open-infrastructure-system-config.links1
-rwxr-xr-xdebian/open-infrastructure-system-config.postinst22
-rwxr-xr-xdebian/open-infrastructure-system-config.postrm31
-rwxr-xr-xdebian/rules72
-rw-r--r--debian/source/format1
-rw-r--r--debian/upstream/signing-key.asc14
-rw-r--r--debian/watch2
12 files changed, 353 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..37b7d1b
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,9 @@
+open-infrastructure-system-tools (20190202-1) unstable; urgency=medium
+
+ * Initial upload to sid, merging:
+ - open-infrastructure-system-boot
+ - open-infrastructure-system-build
+ - open-infrastructure-system-config
+ - open-infrastructure-system-images
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Sat, 02 Feb 2019 11:37:07 +0100
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..edd0757
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,114 @@
+Source: open-infrastructure-system-tools
+Section: admin
+Priority: optional
+Maintainer: Daniel Baumann <daniel.baumann@progress-linux.org>
+Build-Depends:
+ asciidoc,
+ debhelper-compat (= 12),
+ docbook-xml,
+ docbook-xsl,
+ libxml2-utils,
+ xsltproc,
+Rules-Requires-Root: no
+Standards-Version: 4.3.0
+Homepage: https://open-infrastructure.net/software/system-tools
+Vcs-Browser: https://git.progress-linux.org/users/daniel.baumann/debian/packages/open-infrastructure-system-tools
+Vcs-Git: https://git.progress-linux.org/users/daniel.baumann/debian/packages/open-infrastructure-system-tools
+
+Package: open-infrastructure-system-boot
+Section: admin
+Architecture: all
+Depends:
+ busybox | busybox-initramfs,
+ initramfs-tools,
+ udev,
+ ${misc:Depends},
+Recommends:
+ rsync,
+ uuid-runtime,
+Suggests:
+ cryptsetup,
+ curlftpfs,
+ httpfs2,
+ wget,
+Conflicts:
+ live-boot,
+ live-boot-doc,
+ live-boot-initramfs-tools,
+Replaces:
+ live-boot,
+ live-boot-doc,
+ live-boot-initramfs-tools,
+Provides:
+ system-boot,
+Description: Boot Debian-based system images
+ system-boot provides the system integration for booting from a read-only root
+ filesystem such as a live system.
+
+Package: open-infrastructure-system-build
+Section: admin
+Architecture: all
+Depends:
+ debootstrap,
+ ${misc:Depends},
+Recommends:
+ apt-utils,
+ cpio,
+ live-manual-html | live-manual,
+ wget,
+Suggests:
+ debian-keyring,
+ gpgv,
+Conflicts:
+ live-build,
+Replaces:
+ live-build,
+Provides:
+ system-build,
+Description: Build Debian-based system images
+ system-build is a tool to build system images such as a live system from a
+ configuration directory.
+
+Package: open-infrastructure-system-config
+Section: admin
+Architecture: all
+Depends:
+ systemd,
+ ${misc:Depends},
+Recommends:
+ dbus,
+ iproute2 | iproute,
+ keyboard-configuration,
+ locales | locales-all,
+ sudo,
+ user-setup,
+Suggests:
+ pciutils,
+ wget,
+Conflicts:
+ live-config,
+ live-config-doc,
+ live-config-systemd,
+ live-config-sysvinit,
+Replaces:
+ live-config,
+ live-config-doc,
+ live-config-systemd,
+ live-config-sysvinit,
+Provides:
+ system-config,
+Description: Configure Debian-based system images
+ system-config provides the system integration for configuring a read-only root
+ filesystem such as a live system.
+
+Package: open-infrastructure-system-images
+Section: admin
+Architecture: all
+Depends:
+ open-infrastructure-system-build (>= 20161115),
+ ${misc:Depends},
+Provides:
+ system-images,
+Description: Debian-based system images
+ system-images contains the configuration directories for system-build to
+ build live system images.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..42a1323
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,32 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: system-tools
+Upstream-Contact: Open Infrastructure <software@lists.open-infrastructure.net>
+Source: https://git.open-infrastructure.net/software/system-tools
+
+Files: *
+Copyright: 2006-2019 Daniel Baumann <mail@daniel-baumann.ch>
+License: GPL-3+
+
+Files: system-boot/*
+Copyright: 2006-2019 Daniel Baumann <mail@daniel-baumann.ch>
+ 2005-2008 Canonical Ltd. <http://www.cannonical.com/>
+ 2008 Chris Lamb <chris@debian.org>
+ 2006-2007 Marco Amadori <marco.amadori@gmail.com>
+License: GPL-3+
+
+License: GPL-3+
+ This program is free software: you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation, either version 3 of the License, or
+ (at your option) any later version.
+ .
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ .
+ You should have received a copy of the GNU General Public License
+ along with this program. If not, see <http://www.gnu.org/licenses/>.
+ .
+ The complete text of the GNU General Public License
+ can be found in /usr/share/common-licenses/GPL-3 file.
diff --git a/debian/open-infrastructure-system-boot.postinst b/debian/open-infrastructure-system-boot.postinst
new file mode 100755
index 0000000..35b9e86
--- /dev/null
+++ b/debian/open-infrastructure-system-boot.postinst
@@ -0,0 +1,27 @@
+#!/bin/sh
+
+set -e
+
+case "${1}" in
+ configure)
+ mkdir -p /etc/live/boot
+
+ if [ -x "$(which update-initramfs 2>/dev/null)" ] && [ -e /etc/initramfs-tools/initramfs.conf ]
+ then
+ update-initramfs -u
+ fi
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/open-infrastructure-system-boot.postrm b/debian/open-infrastructure-system-boot.postrm
new file mode 100755
index 0000000..5c7cdf7
--- /dev/null
+++ b/debian/open-infrastructure-system-boot.postrm
@@ -0,0 +1,28 @@
+#!/bin/sh
+
+set -e
+
+case "${1}" in
+ purge)
+ rmdir --ignore-fail-on-non-empty /etc/live/boot > /dev/null 2>&1 || true
+ rmdir --ignore-fail-on-non-empty /etc/live > /dev/null 2>&1 || true
+
+ if [ -x "$(which update-initramfs 2>/dev/null)" ] && [ -e /etc/initramfs-tools/initramfs.conf ]
+ then
+ update-initramfs -u
+ fi
+ ;;
+
+ remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
+
+ ;;
+
+ *)
+ echo "postrm called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/open-infrastructure-system-config.links b/debian/open-infrastructure-system-config.links
new file mode 100644
index 0000000..bf4c3d8
--- /dev/null
+++ b/debian/open-infrastructure-system-config.links
@@ -0,0 +1 @@
+/lib/systemd/system/live-config.service /lib/systemd/system/basic.target.wants/live-config.service
diff --git a/debian/open-infrastructure-system-config.postinst b/debian/open-infrastructure-system-config.postinst
new file mode 100755
index 0000000..615fb48
--- /dev/null
+++ b/debian/open-infrastructure-system-config.postinst
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+set -e
+
+case "${1}" in
+ configure)
+ mkdir -p /etc/live/config.conf.d
+ ;;
+
+ abort-upgrade|abort-remove|abort-deconfigure)
+
+ ;;
+
+ *)
+ echo "postinst called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/open-infrastructure-system-config.postrm b/debian/open-infrastructure-system-config.postrm
new file mode 100755
index 0000000..019fe5e
--- /dev/null
+++ b/debian/open-infrastructure-system-config.postrm
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+set -e
+
+case "${1}" in
+ purge)
+ rm -f /etc/sudoers.d/live
+ rm -f /etc/profile.d/zz-live-config_*.sh
+ rm -f /etc/X11/xorg.conf.d/zz-live-config_xserver-xorg.conf
+ rm -f /etc/systemd/system/getty@tty*.service.d/live-config_autologin.conf
+
+ rmdir --ignore-fail-on-non-empty /etc/live/config.conf.d > /dev/null 2>&1 || true
+ rmdir --ignore-fail-on-non-empty /etc/live > /dev/null 2>&1 || true
+
+ rm -rf /var/lib/live/config
+ rmdir --ignore-fail-on-non-empty /var/lib/live > /dev/null 2>&1 || true
+ ;;
+
+ remove|upgrade|failed-upgrade|abort-install|abort-upgrade|disappear)
+
+ ;;
+
+ *)
+ echo "postrm called with unknown argument \`${1}'" >&2
+ exit 1
+ ;;
+esac
+
+#DEBHELPER#
+
+exit 0
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..40bb80f
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,72 @@
+#!/usr/bin/make -f
+
+%:
+ dh ${@}
+
+override_dh_auto_clean:
+ dh_auto_clean
+
+ $(MAKE) -C system-boot clean
+ $(MAKE) -C system-build clean
+ $(MAKE) -C system-config clean
+ $(MAKE) -C system-images clean
+
+override_dh_auto_build:
+ dh_auto_build
+
+ $(MAKE) -C system-boot
+ $(MAKE) -C system-build
+ $(MAKE) -C system-config
+ $(MAKE) -C system-images
+
+override_dh_auto_install:
+ dh_auto_install
+
+ $(MAKE) -C system-boot install DESTDIR=$(CURDIR)/debian/open-infrastructure-system-boot
+ $(MAKE) -C system-build install DESTDIR=$(CURDIR)/debian/open-infrastructure-system-build
+ $(MAKE) -C system-config install DESTDIR=$(CURDIR)/debian/open-infrastructure-system-config
+ $(MAKE) -C system-images install DESTDIR=$(CURDIR)/debian/open-infrastructure-system-images
+
+ # Removing useless files
+ rm -rf debian/*/usr/share/doc/live-boot
+ rm -f debian/*/bin/live-swapfile
+
+ rm -rf debian/*/usr/share/doc/live-build
+
+ rm -f debian/open-infrastructure-system-images/usr/share/doc/system-images/CHANGELOG.txt
+ rm -f debian/open-infrastructure-system-images/usr/share/doc/system-images/LICENSE.txt
+ mv debian/open-infrastructure-system-images/usr/share/doc/system-images debian/open-infrastructure-system-images/usr/share/doc/open-infrastructure-system-images
+
+override_dh_compress:
+ dh_compress -Xusr/share/doc/open-infrastructure-system-config/examples -Xusr/share/system-images
+
+ # Recompressing without timestamp
+ cd debian/open-infrastructure-system-build/usr/share/live/build/bootloaders/grub-legacy && \
+ gunzip splash.xpm.gz && \
+ gzip -n splash.xpm
+
+ # Using systemd instead of sysvinit
+ rm -rf debian/*/etc/init.d
+ rm -f debian/*/lib/live/config/*-sysvinit
+ rm -f debian/*/lib/live/config/*-sysv-rc
+
+ # Using user-setup instead of live-debconfig
+ rm -f debian/tmp/live/config/*live-debconfig*
+
+ # Removing unused files
+ rm -rf debian/*/usr/share/doc/live-config
+ rm -f debian/*/bin/live-config-update
+
+override_dh_link:
+ dh_link
+
+ # workaround dh_link convertion of absolute symlinks to relvative symlinks
+ rm -rf debian/open-infrastructure-system-build/usr/share/live/build/bootloaders
+ cp -a system-build/share/bootloaders debian/open-infrastructure-system-build/usr/share/live/build/bootloaders
+
+ for DIRECTORY in debian/*/usr/share/system-images/*; \
+ do \
+ IMAGE="$$(basename $${DIRECTORY})"; \
+ rm -rf debian/open-infrastructure-system-images/usr/share/system-images/$${IMAGE}/config/bootloaders; \
+ cp -a system-images/share/images/$${IMAGE}/config/bootloaders debian/open-infrastructure-system-images/usr/share/system-images/$${IMAGE}/config/bootloaders; \
+ done
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/upstream/signing-key.asc b/debian/upstream/signing-key.asc
new file mode 100644
index 0000000..1e1884d
--- /dev/null
+++ b/debian/upstream/signing-key.asc
@@ -0,0 +1,14 @@
+-----BEGIN PGP PUBLIC KEY BLOCK-----
+
+mDMEXAKTMBYJKwYBBAHaRw8BAQdAqmmCJDP5dgZLR8JflHZa4QF86ahh9gW7/5bd
+HUkkrsS0N0RhbmllbCBCYXVtYW5uIDxkYW5pZWwuYmF1bWFubkBvcGVuLWluZnJh
+c3RydWN0dXJlLm5ldD6IkAQTFggAOBYhBIrjR8Yn591RIGv9hLYsYaELkxlfBQJc
+ApMwAhsDBQsJCAcCBhUKCQgLAgQWAgMBAh4BAheAAAoJELYsYaELkxlf2NUBAPyZ
+GPLameJQ0qqdYhLW9fXqZgsnEEjndBJJWcCgpPolAQDfovZ1AsjVssTV9vcajOWw
+dNa6PGI/gWqoCCqsbK4GC7g4BFwCkzASCisGAQQBl1UBBQEBB0C0e0KJyQVQE8de
+THs48MotPKrefjhM0a22iziA8jWkXQMBCAeIeAQYFggAIBYhBIrjR8Yn591RIGv9
+hLYsYaELkxlfBQJcApMwAhsMAAoJELYsYaELkxlfMIwA/1JQ/fItM3rCfXb/yKIL
+5CNQ4UhrEY0YPHjhAAJAQ8bFAQDlQbUiVlqDVatOh+BIK6cPGjE+FYvuRArIuZHv
+rlmxCA==
+=Tn5F
+-----END PGP PUBLIC KEY BLOCK-----
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..7810788
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,2 @@
+version=4
+opts=pgpmode=auto https://files.open-infrastructure.net/software/system-tools/upstream/system-tools-(.+)\.tar\.lz