summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2021-01-30 08:01:49 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2021-01-30 08:44:30 +0000
commit9f720241a0dfa530ab75f43319239f58353568af (patch)
treefc3dbf8429ed3fd3fbd6e99d7e2e216c3e31fa90
parentAdding upstream version 2.1.2. (diff)
downloadpendulum-9f720241a0dfa530ab75f43319239f58353568af.tar.xz
pendulum-9f720241a0dfa530ab75f43319239f58353568af.zip
Adding debian version 2.1.2-1.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog6
-rw-r--r--debian/control25
-rw-r--r--debian/copyright31
-rw-r--r--debian/local/setup.py65
-rwxr-xr-xdebian/rules18
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch3
7 files changed, 149 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..9bfa66c
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,6 @@
+pendulum (2.1.2-1) sid; urgency=medium
+
+ * Initial upload to sid (Closes: #892283),
+ required for pgcli (#972598) which moved from humanize to pendulum.
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Sat, 30 Jan 2021 08:58:08 +0100
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..ccba287
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,25 @@
+Source: pendulum
+Section: python
+Priority: optional
+Maintainer: Daniel Baumann <daniel.baumann@progress-linux.org>
+Build-Depends:
+ debhelper-compat (= 13),
+ dh-python,
+ python3-all-dev,
+ python3-setuptools,
+Rules-Requires-Root: no
+Standards-Version: 4.5.1
+Homepage: https://pendulum.eustace.io
+Vcs-Browser: https://git.progress-linux.org/users/daniel.baumann/debian/packages/pendulum
+Vcs-Git: https://git.progress-linux.org/users/daniel.baumann/debian/packages/pendulum
+
+Package: python3-pendulum
+Section: python
+Architecture: any
+Depends:
+ ${misc:Depends},
+ ${python3:Depends},
+Description: Python datetimes made easy
+ Native Python datetime is enough for basic cases, pendulum provides a cleaner
+ and more easy to use API while still relying on the standard library. It’s
+ still datetime but better.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..83e661d
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,31 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: pendulum
+Upstream-Contact: Sébastien Eustace <sebastien@eustace.io>
+Source: https://github.com/sdispater/pendulum/releases
+
+Files: *
+Copyright: 2016-2020 Sébastien Eustace <sebastien@eustace.io>
+License: MIT
+
+Files: debian/*
+Copyright: 2021 Daniel Baumann <daniel.baumann@progress-linux.org>
+License: MIT
+
+License: MIT
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included in
+ all copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+ THE SOFTWARE.
diff --git a/debian/local/setup.py b/debian/local/setup.py
new file mode 100644
index 0000000..5861fdd
--- /dev/null
+++ b/debian/local/setup.py
@@ -0,0 +1,65 @@
+# -*- coding: utf-8 -*-
+
+try:
+ from setuptools import setup
+except ImportError:
+ from distutils.core import setup
+
+import os.path
+
+readme = ''
+here = os.path.abspath(os.path.dirname(__file__))
+readme_path = os.path.join(here, 'README.rst')
+if os.path.exists(readme_path):
+ with open(readme_path, 'rb') as stream:
+ readme = stream.read().decode('utf8')
+
+setup(
+ long_description=readme,
+ name='pendulum',
+ version='2.1.2',
+ description='Python datetimes made easy',
+ python_requires='!=3.0.*,!=3.1.*,!=3.2.*,!=3.3.*,!=3.4.*,<4.0,>=2.7',
+ project_urls={
+ "documentation": "https://pendulum.eustace.io/docs",
+ "homepage": "https://pendulum.eustace.io",
+ "repository": "https://github.com/sdispater/pendulum"
+ },
+ author='Sébastien Eustace',
+ author_email='sebastien@eustace.io',
+ license='MIT',
+ keywords='datetime date time',
+ packages=[
+ 'pendulum', 'pendulum._extensions', 'pendulum.formatting',
+ 'pendulum.locales', 'pendulum.locales.da', 'pendulum.locales.de',
+ 'pendulum.locales.en', 'pendulum.locales.es', 'pendulum.locales.fa',
+ 'pendulum.locales.fo', 'pendulum.locales.fr', 'pendulum.locales.id',
+ 'pendulum.locales.it', 'pendulum.locales.ko', 'pendulum.locales.lt',
+ 'pendulum.locales.nb', 'pendulum.locales.nl', 'pendulum.locales.nn',
+ 'pendulum.locales.pl', 'pendulum.locales.pt_br', 'pendulum.locales.ru',
+ 'pendulum.locales.zh', 'pendulum.mixins', 'pendulum.parsing',
+ 'pendulum.parsing.exceptions', 'pendulum.tz', 'pendulum.tz.data',
+ 'pendulum.tz.zoneinfo', 'pendulum.utils'
+ ],
+ package_dir={"": "."},
+ package_data={
+ "pendulum": ["*.typed"],
+ "pendulum._extensions": ["*.c"],
+ "pendulum.parsing": ["*.c"]
+ },
+ install_requires=[
+ 'python-dateutil==2.*,>=2.6.0', 'pytzdata>=2020.1',
+ 'typing==3.*,>=3.6.0; python_version < "3.5"'
+ ],
+ extras_require={
+ "dev": [
+ "babel==2.*,>=2.5.0", "black==19.*,>=19.3.0.b0",
+ "cleo==0.*,>=0.8.1", "freezegun==0.*,>=0.3.15",
+ "isort==4.*,>=4.3.21", "markdown-include==0.*,>=0.5.1",
+ "mkdocs==1.*,>=1.0.0; python_version == \"3.*\" and python_version >= \"3.5.0\"",
+ "pre-commit==1.*,>=1.10.0", "pygments==2.*,>=2.2.0",
+ "pymdown-extensions==6.*,>=6.0.0", "pytest==4.*,>=4.6.0",
+ "pytest-cov==2.*,>=2.5.0", "pytz>=2018.3", "tox==3.*,>=3.0.0"
+ ]
+ },
+)
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..de010e5
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,18 @@
+#!/usr/bin/make -f
+
+export PYBUILD_NAME=pendulum
+
+%:
+ dh ${@} --buildsystem=pybuild --with python3
+
+execute_before_dh_auto_clean:
+ cp debian/local/setup.py setup.py
+
+execute_after_dh_auto_clean:
+ rm -f setup.py
+
+execute_before_dh_auto_configure:
+ cp debian/local/setup.py setup.py
+
+override_dh_auto_test:
+ # disabled
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..3d33add
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,3 @@
+version=4
+opts=filenamemangle=s/.+\/v?(\d\S+)\.tar\.gz/pendulum-$1\.tar\.gz/ \
+https://github.com/sdispater/pendulum/releases .*/v?(\d\S+)\.tar\.gz