diff options
author | Daniel Baumann <daniel.baumann@progress-linux.org> | 2022-02-21 16:29:07 +0000 |
---|---|---|
committer | Daniel Baumann <daniel.baumann@progress-linux.org> | 2022-02-21 16:29:07 +0000 |
commit | 3b6a991863be64d009e1b700561526e2ecfcd98d (patch) | |
tree | 4d7038cdde9ffce40eaa9280d3f79eaa319044b4 /configure | |
parent | Adding upstream version 1.9. (diff) | |
download | plzip-3b6a991863be64d009e1b700561526e2ecfcd98d.tar.xz plzip-3b6a991863be64d009e1b700561526e2ecfcd98d.zip |
Adding upstream version 1.10.upstream/1.10
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '')
-rwxr-xr-x | configure | 11 |
1 files changed, 8 insertions, 3 deletions
@@ -1,12 +1,12 @@ #! /bin/sh # configure script for Plzip - Massively parallel implementation of lzip -# Copyright (C) 2009-2021 Antonio Diaz Diaz. +# Copyright (C) 2009-2022 Antonio Diaz Diaz. # # This configure script is free software: you have unlimited permission # to copy, distribute, and modify it. pkgname=plzip -pkgversion=1.9 +pkgversion=1.10 progname=plzip with_mingw= srctrigger=doc/${pkgname}.texi @@ -25,6 +25,7 @@ CXX=g++ CPPFLAGS= CXXFLAGS='-Wall -W -O2' LDFLAGS= +LIBS='-llz -lpthread' # checking whether we are using GNU C++. /bin/sh -c "${CXX} --version" > /dev/null 2>&1 || { CXX=c++ ; CXXFLAGS=-O2 ; } @@ -71,6 +72,7 @@ while [ $# != 0 ] ; do echo " CXXFLAGS=OPTIONS command line options for the C++ compiler [${CXXFLAGS}]" echo " CXXFLAGS+=OPTIONS append options to the current value of CXXFLAGS" echo " LDFLAGS=OPTIONS command line options for the linker [${LDFLAGS}]" + echo " LIBS=OPTIONS libraries to pass to the linker [${LIBS}]" echo exit 0 ;; --version | -V) @@ -99,6 +101,7 @@ while [ $# != 0 ] ; do CXXFLAGS=*) CXXFLAGS=${optarg} ;; CXXFLAGS+=*) CXXFLAGS="${CXXFLAGS} ${optarg}" ;; LDFLAGS=*) LDFLAGS=${optarg} ;; + LIBS=*) LIBS="${optarg} ${LIBS}" ;; --*) echo "configure: WARNING: unrecognized option: '${option}'" 1>&2 ;; @@ -168,10 +171,11 @@ echo "CXX = ${CXX}" echo "CPPFLAGS = ${CPPFLAGS}" echo "CXXFLAGS = ${CXXFLAGS}" echo "LDFLAGS = ${LDFLAGS}" +echo "LIBS = ${LIBS}" rm -f Makefile cat > Makefile << EOF # Makefile for Plzip - Massively parallel implementation of lzip -# Copyright (C) 2009-2021 Antonio Diaz Diaz. +# Copyright (C) 2009-2022 Antonio Diaz Diaz. # This file was generated automatically by configure. Don't edit. # # This Makefile is free software: you have unlimited permission @@ -192,6 +196,7 @@ CXX = ${CXX} CPPFLAGS = ${CPPFLAGS} CXXFLAGS = ${CXXFLAGS} LDFLAGS = ${LDFLAGS} +LIBS = ${LIBS} EOF cat "${srcdir}/Makefile.in" >> Makefile |