summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog5
-rw-r--r--debian/control28
-rw-r--r--debian/copyright32
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch3
6 files changed, 73 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..ff08208
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pre-commit-hooks (4.1.0-1) sid; urgency=medium
+
+ * Initial upload to sid (Closes: #1004549).
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Sun, 30 Jan 2022 12:03:35 +0100
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..5c08b7f
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,28 @@
+Source: pre-commit-hooks
+Section: utils
+Priority: optional
+Maintainer: Daniel Baumann <daniel.baumann@progress-linux.org>
+Build-Depends:
+ debhelper-compat (= 13),
+ dh-sequence-python3,
+ python3-all,
+ python3-setuptools,
+Rules-Requires-Root: no
+Standards-Version: 4.6.0
+Homepage: https://pre-commit.com
+Vcs-Browser: https://git.progress-linux.org/users/daniel.baumann/debian/packages/pre-commit-hooks
+Vcs-Git: https://git.progress-linux.org/users/daniel.baumann/debian/packages/pre-commit-hooks
+
+Package: pre-commit-hooks
+Architecture: all
+Depends:
+ pre-commit,
+ ${misc:Depends},
+ ${python3:Depends},
+Enhances:
+ pre-commit,
+Description: Git pre-commit hook framework (hooks)
+ pre-commit is a framework for managing and maintaining multi-language Git
+ pre-commit hooks.
+ .
+ This package contains some out-of-the-box hooks.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..d45d65b
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,32 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: pre-commit-hooks
+Upstream-Contact: Ken Struys <ken@struys.ca>
+Source: https://github.com/pre-commit/pre-commit-hooks/releases
+
+Files: *
+Copyright: 2014-2022 Anthony Sottile <asottile@umich.edu>
+ 2014-2022 Ken Struys <ken@struys.ca>
+License: MIT
+
+Files: debian/*
+Copyright: 2022 Daniel Baumann <daniel.baumann@progress-linux.org>
+License: MIT
+
+License: MIT
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included in
+ all copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+ THE SOFTWARE.
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..cfe26c0
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,4 @@
+#!/usr/bin/make -f
+
+%:
+ dh ${@} --buildsystem=pybuild
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..d4c1f55
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,3 @@
+version=4
+opts=filenamemangle=s/.+\/v?(\d\S+)\.tar\.gz/pre-commit-hooks-$1\.tar\.gz/ \
+https://github.com/pre-commit-hooks/pre-commit-hooks/releases .*/v?(\d\S+)\.tar\.gz