summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-24 22:03:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2020-03-25 00:11:42 +0000
commit9a54d5bd88e895bf449f1161d72b272b4c6d711e (patch)
treeb214a6846d74b419ad50760494638b8cf72076fb
parentAdding upstream version 2.2.0. (diff)
downloadpre-commit-9a54d5bd88e895bf449f1161d72b272b4c6d711e.tar.xz
pre-commit-9a54d5bd88e895bf449f1161d72b272b4c6d711e.zip
Adding debian version 2.2.0-1.debian/2.2.0-1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
-rw-r--r--debian/changelog5
-rw-r--r--debian/control26
-rw-r--r--debian/copyright32
-rw-r--r--debian/pre-commit.lintian-overrides2
-rwxr-xr-xdebian/rules4
-rw-r--r--debian/source/format1
-rw-r--r--debian/watch3
7 files changed, 73 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..5e6edbd
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+pre-commit (2.2.0-1) sid; urgency=medium
+
+ * Initial upload to sid (Closes: #793655).
+
+ -- Daniel Baumann <daniel.baumann@progress-linux.org> Tue, 24 Mar 2020 23:00:03 +0100
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..ae98a88
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,26 @@
+Source: pre-commit
+Section: utils
+Priority: optional
+Maintainer: Daniel Baumann <daniel.baumann@progress-linux.org>
+Build-Depends:
+ debhelper (>= 12.8~),
+ debhelper-compat (= 12),
+ dh-python,
+ python3-all,
+ python3-setuptools,
+Rules-Requires-Root: no
+Standards-Version: 4.5.0
+Homepage: https://pre-commit.com
+Vcs-Browser: https://git.progress-linux.org/users/daniel.baumann/debian/packages/pre-commit
+Vcs-Git: https://git.progress-linux.org/users/daniel.baumann/debian/packages/pre-commit
+
+Package: pre-commit
+Architecture: all
+Depends:
+ python3-cfgv,
+ python3-identify,
+ python3-importlib-metadata,
+ ${misc:Depends},
+ ${python3:Depends},
+Description: Git pre-commit hook framework
+ A framework for managing and maintaining multi-language Git pre-commit hooks.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..ce72e84
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,32 @@
+Format: https://www.debian.org/doc/packaging-manuals/copyright-format/1.0/
+Upstream-Name: identify
+Upstream-Contact: Ken Struys <ken@struys.ca>
+Source: https://github.com/pre-commit/pre-commit/releases
+
+Files: *
+Copyright: 2014-2020 Anthony Sottile <asottile@umich.edu>
+ 2014-2020 Ken Struys <ken@struys.ca>
+License: MIT
+
+Files: debian/*
+Copyright: 2020 Daniel Baumann <daniel.baumann@progress-linux.org>
+License: MIT
+
+License: MIT
+ Permission is hereby granted, free of charge, to any person obtaining a copy
+ of this software and associated documentation files (the "Software"), to deal
+ in the Software without restriction, including without limitation the rights
+ to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ copies of the Software, and to permit persons to whom the Software is
+ furnished to do so, subject to the following conditions:
+ .
+ The above copyright notice and this permission notice shall be included in
+ all copies or substantial portions of the Software.
+ .
+ THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+ THE SOFTWARE.
diff --git a/debian/pre-commit.lintian-overrides b/debian/pre-commit.lintian-overrides
new file mode 100644
index 0000000..ec9ae2f
--- /dev/null
+++ b/debian/pre-commit.lintian-overrides
@@ -0,0 +1,2 @@
+# false-positive
+pre-commit: package-contains-npm-ignore-file usr/lib/python3/dist-packages/pre_commit/resources/empty_template_.npmignore
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..9d2590c
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,4 @@
+#!/usr/bin/make -f
+
+%:
+ dh ${@} --buildsystem=pybuild --with python3
diff --git a/debian/source/format b/debian/source/format
new file mode 100644
index 0000000..163aaf8
--- /dev/null
+++ b/debian/source/format
@@ -0,0 +1 @@
+3.0 (quilt)
diff --git a/debian/watch b/debian/watch
new file mode 100644
index 0000000..62a87f0
--- /dev/null
+++ b/debian/watch
@@ -0,0 +1,3 @@
+version=4
+opts=filenamemangle=s/.+\/v?(\d\S+)\.tar\.gz/pre-commit-$1\.tar\.gz/ \
+https://github.com/pre-commit/pre-commit/releases .*/v?(\d\S+)\.tar\.gz