summaryrefslogtreecommitdiffstats
path: root/testing/resources/perl_hooks_repo
diff options
context:
space:
mode:
Diffstat (limited to 'testing/resources/perl_hooks_repo')
-rw-r--r--testing/resources/perl_hooks_repo/.gitignore7
-rw-r--r--testing/resources/perl_hooks_repo/.pre-commit-hooks.yaml5
-rw-r--r--testing/resources/perl_hooks_repo/MANIFEST4
-rw-r--r--testing/resources/perl_hooks_repo/Makefile.PL10
-rwxr-xr-xtesting/resources/perl_hooks_repo/bin/pre-commit-perl-hello7
-rw-r--r--testing/resources/perl_hooks_repo/lib/PreCommitHello.pm12
6 files changed, 0 insertions, 45 deletions
diff --git a/testing/resources/perl_hooks_repo/.gitignore b/testing/resources/perl_hooks_repo/.gitignore
deleted file mode 100644
index 7af9940..0000000
--- a/testing/resources/perl_hooks_repo/.gitignore
+++ /dev/null
@@ -1,7 +0,0 @@
-/MYMETA.json
-/MYMETA.yml
-/Makefile
-/PreCommitHello-*.tar.*
-/PreCommitHello-*/
-/blib/
-/pm_to_blib
diff --git a/testing/resources/perl_hooks_repo/.pre-commit-hooks.yaml b/testing/resources/perl_hooks_repo/.pre-commit-hooks.yaml
deleted file mode 100644
index 11e6f6c..0000000
--- a/testing/resources/perl_hooks_repo/.pre-commit-hooks.yaml
+++ /dev/null
@@ -1,5 +0,0 @@
-- id: perl-hook
- name: perl example hook
- entry: pre-commit-perl-hello
- language: perl
- files: ''
diff --git a/testing/resources/perl_hooks_repo/MANIFEST b/testing/resources/perl_hooks_repo/MANIFEST
deleted file mode 100644
index 4a20084..0000000
--- a/testing/resources/perl_hooks_repo/MANIFEST
+++ /dev/null
@@ -1,4 +0,0 @@
-MANIFEST
-Makefile.PL
-bin/pre-commit-perl-hello
-lib/PreCommitHello.pm
diff --git a/testing/resources/perl_hooks_repo/Makefile.PL b/testing/resources/perl_hooks_repo/Makefile.PL
deleted file mode 100644
index 6c70e10..0000000
--- a/testing/resources/perl_hooks_repo/Makefile.PL
+++ /dev/null
@@ -1,10 +0,0 @@
-use strict;
-use warnings;
-
-use ExtUtils::MakeMaker;
-
-WriteMakefile(
- NAME => "PreCommitHello",
- VERSION_FROM => "lib/PreCommitHello.pm",
- EXE_FILES => [qw(bin/pre-commit-perl-hello)],
-);
diff --git a/testing/resources/perl_hooks_repo/bin/pre-commit-perl-hello b/testing/resources/perl_hooks_repo/bin/pre-commit-perl-hello
deleted file mode 100755
index 9474009..0000000
--- a/testing/resources/perl_hooks_repo/bin/pre-commit-perl-hello
+++ /dev/null
@@ -1,7 +0,0 @@
-#!/usr/bin/env perl
-
-use strict;
-use warnings;
-use PreCommitHello;
-
-PreCommitHello::hello();
diff --git a/testing/resources/perl_hooks_repo/lib/PreCommitHello.pm b/testing/resources/perl_hooks_repo/lib/PreCommitHello.pm
deleted file mode 100644
index c76521c..0000000
--- a/testing/resources/perl_hooks_repo/lib/PreCommitHello.pm
+++ /dev/null
@@ -1,12 +0,0 @@
-package PreCommitHello;
-
-use strict;
-use warnings;
-
-our $VERSION = "0.1.0";
-
-sub hello {
- print "Hello from perl-commit Perl!\n";
-}
-
-1;