summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorDaniel Baumann <mail@daniel-baumann.ch>2023-12-17 10:46:40 +0000
committerDaniel Baumann <mail@daniel-baumann.ch>2023-12-17 10:46:40 +0000
commit4e61276ae3a4432a9d7a65dd49eb6ae71dd5f93a (patch)
tree57f9ac8ea7edafc3db4db312b8a369ab39711636 /pyproject.toml
parentAdding upstream version 3.0.23. (diff)
downloadptpython-4e61276ae3a4432a9d7a65dd49eb6ae71dd5f93a.tar.xz
ptpython-4e61276ae3a4432a9d7a65dd49eb6ae71dd5f93a.zip
Adding upstream version 3.0.25.upstream/3.0.25
Signed-off-by: Daniel Baumann <mail@daniel-baumann.ch>
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml48
1 files changed, 35 insertions, 13 deletions
diff --git a/pyproject.toml b/pyproject.toml
index b356239..5421c45 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,13 +1,35 @@
-[tool.black]
-target-version = ['py36']
-
-
-[tool.isort]
-# isort configuration that is compatible with Black.
-multi_line_output = 3
-include_trailing_comma = true
-known_first_party = "ptpython"
-known_third_party = "prompt_toolkit,pygments,asyncssh"
-force_grid_wrap = 0
-use_parentheses = true
-line_length = 88
+[tool.ruff]
+target-version = "py37"
+select = [
+ "E", # pycodestyle errors
+ "W", # pycodestyle warnings
+ "F", # pyflakes
+ "C", # flake8-comprehensions
+ "T", # Print.
+ "I", # isort
+ # "B", # flake8-bugbear
+ "UP", # pyupgrade
+ "RUF100", # unused-noqa
+ "Q", # quotes
+]
+ignore = [
+ "E501", # Line too long, handled by black
+ "C901", # Too complex
+ "E722", # bare except.
+]
+
+
+[tool.ruff.per-file-ignores]
+"examples/*" = ["T201"] # Print allowed in examples.
+"examples/ptpython_config/config.py" = ["F401"] # Unused imports in config.
+"ptpython/entry_points/run_ptipython.py" = ["T201", "F401"] # Print, import usage.
+"ptpython/entry_points/run_ptpython.py" = ["T201"] # Print usage.
+"ptpython/ipython.py" = ["T100"] # Import usage.
+"ptpython/repl.py" = ["T201"] # Print usage.
+"ptpython/printer.py" = ["T201"] # Print usage.
+"tests/run_tests.py" = ["F401"] # Unused imports.
+
+
+[tool.ruff.isort]
+known-first-party = ["ptpython"]
+known-third-party = ["prompt_toolkit", "pygments", "asyncssh"]