summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-02-27 10:39:56 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-02-27 10:39:56 +0000
commiteeeaff8afe94b2806a79a02b7c01c912a984a22f (patch)
tree97983910e3beb2f21c346165f69f3fc57a411b15 /setup.py
parentAdding upstream version 3.0.22. (diff)
downloadptpython-eeeaff8afe94b2806a79a02b7c01c912a984a22f.tar.xz
ptpython-eeeaff8afe94b2806a79a02b7c01c912a984a22f.zip
Adding upstream version 3.0.23.upstream/3.0.23
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index 2725dac..18d2911 100644
--- a/setup.py
+++ b/setup.py
@@ -11,7 +11,7 @@ with open(os.path.join(os.path.dirname(__file__), "README.rst")) as f:
setup(
name="ptpython",
author="Jonathan Slenders",
- version="3.0.22",
+ version="3.0.23",
url="https://github.com/prompt-toolkit/ptpython",
description="Python REPL build on top of prompt_toolkit",
long_description=long_description,
@@ -21,14 +21,14 @@ setup(
"appdirs",
"importlib_metadata;python_version<'3.8'",
"jedi>=0.16.0",
- # Use prompt_toolkit 3.0.18, because of the `in_thread` option.
- "prompt_toolkit>=3.0.18,<3.1.0",
+ # Use prompt_toolkit 3.0.28, because of cursor shape support.
+ "prompt_toolkit>=3.0.28,<3.1.0",
"pygments",
],
- python_requires=">=3.6",
+ python_requires=">=3.7",
classifiers=[
"Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.7",
"Programming Language :: Python :: 3.8",
"Programming Language :: Python :: 3 :: Only",