diff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 12 |
1 files changed, 7 insertions, 5 deletions
@@ -11,7 +11,7 @@ with open(os.path.join(os.path.dirname(__file__), "README.rst")) as f: setup( name="ptpython", author="Jonathan Slenders", - version="3.0.16", + version="3.0.19", url="https://github.com/prompt-toolkit/ptpython", description="Python REPL build on top of prompt_toolkit", long_description=long_description, @@ -20,10 +20,9 @@ setup( "appdirs", "importlib_metadata;python_version<'3.8'", "jedi>=0.16.0", - # Use prompt_toolkit 3.0.16, because of the `DeduplicateCompleter`. - "prompt_toolkit>=3.0.16,<3.1.0", + # Use prompt_toolkit 3.0.18, because of the `in_thread` option. + "prompt_toolkit>=3.0.18,<3.1.0", "pygments", - "black", ], python_requires=">=3.6", classifiers=[ @@ -47,5 +46,8 @@ setup( % sys.version_info[:2], ] }, - extras_require={"ptipython": ["ipython"]}, # For ptipython, we need to have IPython + extras_require={ + "ptipython": ["ipython"], # For ptipython, we need to have IPython + "all": ["black"], # Black not always possible on PyPy + }, ) |