summaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml59
1 files changed, 59 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..5a88369
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,59 @@
+[build-system]
+requires = ['flit_core >=3.2,<4']
+build-backend = 'flit_core.buildapi'
+
+[project]
+name = 'pydyf'
+description = 'A low-level PDF generator.'
+keywords = ['pdf', 'generator']
+authors = [{name = 'CourtBouillon', email = 'contact@courtbouillon.org'}]
+maintainers = [{name = 'CourtBouillon', email = 'contact@courtbouillon.org'}]
+requires-python = '>=3.6'
+readme = {file = 'README.rst', content-type = 'text/x-rst'}
+license = {file = 'LICENSE'}
+classifiers = [
+ 'Development Status :: 4 - Beta',
+ 'Intended Audience :: Developers',
+ 'License :: OSI Approved :: BSD License',
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3 :: Only',
+ 'Programming Language :: Python :: 3.6',
+ 'Programming Language :: Python :: 3.7',
+ 'Programming Language :: Python :: 3.8',
+ 'Programming Language :: Python :: 3.9',
+ 'Programming Language :: Python :: Implementation :: CPython',
+ 'Programming Language :: Python :: Implementation :: PyPy',
+]
+dynamic = ['version']
+
+[project.urls]
+Homepage = 'https://www.courtbouillon.org/pydyf'
+Documentation = 'https://doc.courtbouillon.org/pydyf/'
+Code = 'https://github.com/CourtBouillon/pydyf'
+Issues = 'https://github.com/CourtBouillon/pydyf/issues'
+Changelog = 'https://github.com/CourtBouillon/pydyf/releases'
+Donation = 'https://opencollective.com/courtbouillon'
+
+[project.optional-dependencies]
+doc = ['sphinx', 'sphinx_rtd_theme']
+test = ['pytest', 'pytest-cov', 'pytest-flake8', 'pytest-isort', 'coverage[toml]', 'pillow']
+
+[tool.flit.sdist]
+exclude = ['.*']
+
+[tool.pytest.ini_options]
+addopts = '--isort --flake8 --cov --no-cov-on-fail'
+
+[tool.coverage.run]
+branch = true
+include = ['tests/*', 'pydyf/*']
+
+[tool.coverage.report]
+exclude_lines = ['pragma: no cover', 'def __repr__', 'raise NotImplementedError']
+omit = ['.*']
+
+[tool.isort]
+default_section = 'FIRSTPARTY'
+multi_line_output = 4