summaryrefslogtreecommitdiffstats
path: root/tests/test_version.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-07-29 09:40:12 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-07-29 09:40:12 +0000
commit14b40ec77a4bf8605789cc3aff0eb87625510a41 (patch)
tree4064d27144d6deaabfcd96df01bd996baa8b51a0 /tests/test_version.py
parentInitial commit. (diff)
downloadpython-aristaproto-14b40ec77a4bf8605789cc3aff0eb87625510a41.tar.xz
python-aristaproto-14b40ec77a4bf8605789cc3aff0eb87625510a41.zip
Adding upstream version 1.2+20240521.upstream/1.2+20240521upstream
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tests/test_version.py')
-rw-r--r--tests/test_version.py16
1 files changed, 16 insertions, 0 deletions
diff --git a/tests/test_version.py b/tests/test_version.py
new file mode 100644
index 0000000..bfbe842
--- /dev/null
+++ b/tests/test_version.py
@@ -0,0 +1,16 @@
+from pathlib import Path
+
+import tomlkit
+
+from aristaproto import __version__
+
+
+PROJECT_TOML = Path(__file__).joinpath("..", "..", "pyproject.toml").resolve()
+
+
+def test_version():
+ with PROJECT_TOML.open() as toml_file:
+ project_config = tomlkit.loads(toml_file.read())
+ assert (
+ __version__ == project_config["tool"]["poetry"]["version"]
+ ), "Project version should match in package and package config"