summaryrefslogtreecommitdiffstats
path: root/.pre-commit-config.yaml
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2023-01-04 07:24:05 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2023-01-04 07:24:05 +0000
commit621555af37594a213d91ea113d5fc7739af84d40 (patch)
tree5aaa3b586692062accffc21cfaaa5a3917ee77b3 /.pre-commit-config.yaml
parentAdding upstream version 10.2.9. (diff)
downloadsqlglot-621555af37594a213d91ea113d5fc7739af84d40.tar.xz
sqlglot-621555af37594a213d91ea113d5fc7739af84d40.zip
Adding upstream version 10.4.2.upstream/10.4.2
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to '.pre-commit-config.yaml')
-rw-r--r--.pre-commit-config.yaml31
1 files changed, 31 insertions, 0 deletions
diff --git a/.pre-commit-config.yaml b/.pre-commit-config.yaml
new file mode 100644
index 0000000..17ffb61
--- /dev/null
+++ b/.pre-commit-config.yaml
@@ -0,0 +1,31 @@
+repos:
+ - repo: local
+ hooks:
+ - id: autoflake
+ name: autoflake
+ entry: autoflake -i -r
+ language: system
+ types: [ python ]
+ require_serial: true
+ files: ^(sqlglot/|tests/|setup.py)
+ - id: isort
+ name: isort
+ entry: isort
+ language: system
+ types: [ python ]
+ files: ^(sqlglot/|tests/|setup.py)
+ require_serial: true
+ - id: black
+ name: black
+ entry: black --line-length 100
+ language: system
+ types: [ python ]
+ require_serial: true
+ files: ^(sqlglot/|tests/|setup.py)
+ - id: mypy
+ name: mypy
+ entry: mypy
+ language: system
+ types: [ python ]
+ files: ^(sqlglot/|tests/)
+ require_serial: true