diff options
author | Daniel Baumann <daniel.baumann@progress-linux.org> | 2023-12-19 11:01:36 +0000 |
---|---|---|
committer | Daniel Baumann <daniel.baumann@progress-linux.org> | 2023-12-19 11:01:36 +0000 |
commit | 948a422be120c069e48c63a8770fec7204307897 (patch) | |
tree | 80bc02d5e6cd3527409386aa1d706272bea54e6c /Makefile | |
parent | Adding upstream version 20.1.0. (diff) | |
download | sqlglot-948a422be120c069e48c63a8770fec7204307897.tar.xz sqlglot-948a422be120c069e48c63a8770fec7204307897.zip |
Adding upstream version 20.3.0.upstream/20.3.0
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'Makefile')
-rw-r--r-- | Makefile | 22 |
1 files changed, 18 insertions, 4 deletions
@@ -3,22 +3,36 @@ install: pip install -e . -install-dev: +install-dev-rs-release: + cd sqlglotrs/ && python -m maturin develop -r + +install-dev-rs: + cd sqlglotrs/ && python -m maturin develop + +install-dev-core: pip install -e ".[dev]" +install-dev: install-dev-core install-dev-rs + install-pre-commit: pre-commit install test: - python -m unittest + SQLGLOTRS_TOKENIZER=0 python -m unittest + +test-rs: + RUST_BACKTRACE=1 python -m unittest unit: - SKIP_INTEGRATION=1 python -m unittest + SKIP_INTEGRATION=1 SQLGLOTRS_TOKENIZER=0 python -m unittest + +unit-rs: + SKIP_INTEGRATION=1 RUST_BACKTRACE=1 python -m unittest style: pre-commit run --all-files -check: style test +check: style test test-rs docs: python pdoc/cli.py -o docs |