diff options
author | Daniel Baumann <daniel.baumann@progress-linux.org> | 2023-12-19 11:01:55 +0000 |
---|---|---|
committer | Daniel Baumann <daniel.baumann@progress-linux.org> | 2023-12-19 11:01:55 +0000 |
commit | f1c2dbe3b17a0d5edffbb65b85b642d0bb2756c5 (patch) | |
tree | 5dce0fe2a11381761496eb973c20750f44db56d5 /setup.py | |
parent | Releasing debian version 20.1.0-1. (diff) | |
download | sqlglot-f1c2dbe3b17a0d5edffbb65b85b642d0bb2756c5.tar.xz sqlglot-f1c2dbe3b17a0d5edffbb65b85b642d0bb2756c5.zip |
Merging upstream version 20.3.0.
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 11 |
1 files changed, 11 insertions, 0 deletions
@@ -1,5 +1,14 @@ from setuptools import find_packages, setup + +def sqlglotrs_version(): + with open("sqlglotrs/Cargo.toml") as fd: + for line in fd.readlines(): + if line.strip().startswith("version"): + return line.split("=")[1].strip().strip('"') + raise ValueError("Could not find version in Cargo.toml") + + setup( name="sqlglot", description="An easily customizable SQL parser and transpiler", @@ -31,7 +40,9 @@ setup( "pdoc", "pre-commit", "types-python-dateutil", + "maturin>=1.4,<2.0", ], + "rs": [f"sqlglotrs=={sqlglotrs_version()}"], }, classifiers=[ "Development Status :: 5 - Production/Stable", |