summaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-02-08 05:38:39 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-02-08 05:38:39 +0000
commitaedf35026379f52d7e2b4c1f957691410a758089 (patch)
tree86540364259b66741173d2333387b78d6f9c31e2 /setup.py
parentAdding upstream version 20.11.0. (diff)
downloadsqlglot-aedf35026379f52d7e2b4c1f957691410a758089.tar.xz
sqlglot-aedf35026379f52d7e2b4c1f957691410a758089.zip
Adding upstream version 21.0.1.upstream/21.0.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 2 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 1e2cb92..ba18f64 100644
--- a/setup.py
+++ b/setup.py
@@ -29,16 +29,14 @@ setup(
python_requires=">=3.7",
extras_require={
"dev": [
- "autoflake",
- "black",
"duckdb>=0.6",
- "isort",
- "mypy>=0.990",
+ "mypy",
"pandas",
"pyspark",
"python-dateutil",
"pdoc",
"pre-commit",
+ "ruff",
"types-python-dateutil",
"typing_extensions",
"maturin>=1.4,<2.0",