summaryrefslogtreecommitdiffstats
path: root/sqlglotrs/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'sqlglotrs/pyproject.toml')
-rw-r--r--sqlglotrs/pyproject.toml16
1 files changed, 16 insertions, 0 deletions
diff --git a/sqlglotrs/pyproject.toml b/sqlglotrs/pyproject.toml
new file mode 100644
index 0000000..867cdcc
--- /dev/null
+++ b/sqlglotrs/pyproject.toml
@@ -0,0 +1,16 @@
+[build-system]
+requires = ["maturin>=1.4,<2.0"]
+build-backend = "maturin"
+
+[project]
+name = "sqlglotrs"
+requires-python = ">=3.7"
+classifiers = [
+ "Programming Language :: Rust",
+ "Programming Language :: Python :: Implementation :: CPython",
+ "Programming Language :: Python :: Implementation :: PyPy",
+]
+dynamic = ["version"]
+
+[tool.maturin]
+features = ["pyo3/extension-module"]