summaryrefslogtreecommitdiffstats
path: root/Makefile.in
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.in')
-rw-r--r--Makefile.in16
1 files changed, 9 insertions, 7 deletions
diff --git a/Makefile.in b/Makefile.in
index 0fa5761..a07cb9e 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -8,8 +8,8 @@ SHELL = /bin/sh
CAN_RUN_INSTALLINFO = $(SHELL) -c "install-info --version" > /dev/null 2>&1
objs = arg_parser.o lzip_index.o archive_reader.o common.o common_decode.o \
- compress.o create.o create_lz.o decode.o decode_lz.o delete.o \
- delete_lz.o exclude.o extended.o main.o
+ common_mutex.o compress.o create.o create_lz.o decode.o decode_lz.o \
+ delete.o delete_lz.o exclude.o extended.o main.o
.PHONY : all install install-bin install-info install-man \
@@ -32,13 +32,15 @@ main.o : main.cc
$(objs) : Makefile
arg_parser.o : arg_parser.h
archive_reader.o : tarlz.h lzip_index.h archive_reader.h
-common.o : tarlz.h arg_parser.h
-common_decode.o : tarlz.h arg_parser.h
+common.o : tarlz.h
+common_decode.o : tarlz.h arg_parser.h decode.h
+common_mutex.o : common_mutex.h
compress.o : tarlz.h arg_parser.h
create.o : tarlz.h arg_parser.h create.h
-create_lz.o : tarlz.h arg_parser.h create.h
+create_lz.o : tarlz.h arg_parser.h common_mutex.h create.h
decode.o : tarlz.h arg_parser.h lzip_index.h archive_reader.h decode.h
-decode_lz.o : tarlz.h arg_parser.h lzip_index.h archive_reader.h decode.h
+decode_lz.o : tarlz.h arg_parser.h lzip_index.h archive_reader.h \
+ common_mutex.h decode.h
delete.o : tarlz.h arg_parser.h lzip_index.h archive_reader.h
delete_lz.o : tarlz.h arg_parser.h lzip_index.h archive_reader.h
exclude.o : tarlz.h
@@ -52,7 +54,7 @@ doc : info man
info : $(VPATH)/doc/$(pkgname).info
$(VPATH)/doc/$(pkgname).info : $(VPATH)/doc/$(pkgname).texi
- cd $(VPATH)/doc && makeinfo $(pkgname).texi
+ cd $(VPATH)/doc && $(MAKEINFO) $(pkgname).texi
man : $(VPATH)/doc/$(progname).1