summaryrefslogtreecommitdiffstats
path: root/configure
diff options
context:
space:
mode:
Diffstat (limited to 'configure')
-rwxr-xr-xconfigure73
1 files changed, 39 insertions, 34 deletions
diff --git a/configure b/configure
index e02fcf0..e1e3aac 100755
--- a/configure
+++ b/configure
@@ -1,12 +1,12 @@
#! /bin/sh
# configure script for Tarlz - Archiver with multimember lzip compression
-# Copyright (C) 2013-2022 Antonio Diaz Diaz.
+# Copyright (C) 2013-2023 Antonio Diaz Diaz.
#
# This configure script is free software: you have unlimited permission
# to copy, distribute, and modify it.
pkgname=tarlz
-pkgversion=0.23
+pkgversion=0.24
progname=tarlz
srctrigger=doc/${pkgname}.texi
@@ -25,6 +25,7 @@ CPPFLAGS=
CXXFLAGS='-Wall -W -O2'
LDFLAGS=
LIBS='-llz -lpthread'
+MAKEINFO=makeinfo
# checking whether we are using GNU C++.
/bin/sh -c "${CXX} --version" > /dev/null 2>&1 || { CXX=c++ ; CXXFLAGS=-O2 ; }
@@ -35,7 +36,7 @@ no_create=
while [ $# != 0 ] ; do
# Get the first arg, and shuffle
- option=$1 ; arg2=no
+ option="$1" ; arg2=no
shift
# Add the argument quoted to args
@@ -43,12 +44,12 @@ while [ $# != 0 ] ; do
else args="${args} \"${option}\"" ; fi
# Split out the argument for options that take them
- case ${option} in
- *=*) optarg=`echo "${option}" | sed -e 's,^[^=]*=,,;s,/$,,'` ;;
+ case "${option}" in
+ *=*) optarg="`echo "${option}" | sed -e 's,^[^=]*=,,;s,/$,,'`" ;;
esac
# Process the options
- case ${option} in
+ case "${option}" in
--help | -h)
echo "Usage: $0 [OPTION]... [VAR=VALUE]..."
echo
@@ -58,7 +59,7 @@ while [ $# != 0 ] ; do
echo "Options and variables: [defaults in brackets]"
echo " -h, --help display this help and exit"
echo " -V, --version output version information and exit"
- echo " --srcdir=DIR find the sources in DIR [. or ..]"
+ echo " --srcdir=DIR find the source code in DIR [. or ..]"
echo " --prefix=DIR install into DIR [${prefix}]"
echo " --exec-prefix=DIR base directory for arch-dependent files [${exec_prefix}]"
echo " --bindir=DIR user executables directory [${bindir}]"
@@ -71,34 +72,36 @@ while [ $# != 0 ] ; do
echo " CXXFLAGS+=OPTIONS append options to the current value of CXXFLAGS"
echo " LDFLAGS=OPTIONS command line options for the linker [${LDFLAGS}]"
echo " LIBS=OPTIONS libraries to pass to the linker [${LIBS}]"
+ echo " MAKEINFO=NAME makeinfo program to use [${MAKEINFO}]"
echo
exit 0 ;;
--version | -V)
echo "Configure script for ${pkgname} version ${pkgversion}"
exit 0 ;;
- --srcdir) srcdir=$1 ; arg2=yes ;;
- --prefix) prefix=$1 ; arg2=yes ;;
- --exec-prefix) exec_prefix=$1 ; arg2=yes ;;
- --bindir) bindir=$1 ; arg2=yes ;;
- --datarootdir) datarootdir=$1 ; arg2=yes ;;
- --infodir) infodir=$1 ; arg2=yes ;;
- --mandir) mandir=$1 ; arg2=yes ;;
-
- --srcdir=*) srcdir=${optarg} ;;
- --prefix=*) prefix=${optarg} ;;
- --exec-prefix=*) exec_prefix=${optarg} ;;
- --bindir=*) bindir=${optarg} ;;
- --datarootdir=*) datarootdir=${optarg} ;;
- --infodir=*) infodir=${optarg} ;;
- --mandir=*) mandir=${optarg} ;;
- --no-create) no_create=yes ;;
-
- CXX=*) CXX=${optarg} ;;
- CPPFLAGS=*) CPPFLAGS=${optarg} ;;
- CXXFLAGS=*) CXXFLAGS=${optarg} ;;
+ --srcdir) srcdir="$1" ; arg2=yes ;;
+ --prefix) prefix="$1" ; arg2=yes ;;
+ --exec-prefix) exec_prefix="$1" ; arg2=yes ;;
+ --bindir) bindir="$1" ; arg2=yes ;;
+ --datarootdir) datarootdir="$1" ; arg2=yes ;;
+ --infodir) infodir="$1" ; arg2=yes ;;
+ --mandir) mandir="$1" ; arg2=yes ;;
+
+ --srcdir=*) srcdir="${optarg}" ;;
+ --prefix=*) prefix="${optarg}" ;;
+ --exec-prefix=*) exec_prefix="${optarg}" ;;
+ --bindir=*) bindir="${optarg}" ;;
+ --datarootdir=*) datarootdir="${optarg}" ;;
+ --infodir=*) infodir="${optarg}" ;;
+ --mandir=*) mandir="${optarg}" ;;
+ --no-create) no_create=yes ;;
+
+ CXX=*) CXX="${optarg}" ;;
+ CPPFLAGS=*) CPPFLAGS="${optarg}" ;;
+ CXXFLAGS=*) CXXFLAGS="${optarg}" ;;
CXXFLAGS+=*) CXXFLAGS="${CXXFLAGS} ${optarg}" ;;
- LDFLAGS=*) LDFLAGS=${optarg} ;;
+ LDFLAGS=*) LDFLAGS="${optarg}" ;;
LIBS=*) LIBS="${optarg} ${LIBS}" ;;
+ MAKEINFO=*) MAKEINFO="${optarg}" ;;
--*)
echo "configure: WARNING: unrecognized option: '${option}'" 1>&2 ;;
@@ -118,19 +121,19 @@ while [ $# != 0 ] ; do
fi
done
-# Find the source files, if location was not specified.
+# Find the source code, if location was not specified.
srcdirtext=
if [ -z "${srcdir}" ] ; then
srcdirtext="or . or .." ; srcdir=.
if [ ! -r "${srcdir}/${srctrigger}" ] ; then srcdir=.. ; fi
if [ ! -r "${srcdir}/${srctrigger}" ] ; then
## the sed command below emulates the dirname command
- srcdir=`echo "$0" | sed -e 's,[^/]*$,,;s,/$,,;s,^$,.,'`
+ srcdir="`echo "$0" | sed -e 's,[^/]*$,,;s,/$,,;s,^$,.,'`"
fi
fi
if [ ! -r "${srcdir}/${srctrigger}" ] ; then
- echo "configure: Can't find sources in ${srcdir} ${srcdirtext}" 1>&2
+ echo "configure: Can't find source code in ${srcdir} ${srcdirtext}" 1>&2
echo "configure: (At least ${srctrigger} is missing)." 1>&2
exit 1
fi
@@ -150,7 +153,7 @@ if [ -z "${no_create}" ] ; then
# This script is free software: you have unlimited permission
# to copy, distribute, and modify it.
-exec /bin/sh $0 ${args} --no-create
+exec /bin/sh "$0" ${args} --no-create
EOF
chmod +x config.status
fi
@@ -168,10 +171,11 @@ echo "CPPFLAGS = ${CPPFLAGS}"
echo "CXXFLAGS = ${CXXFLAGS}"
echo "LDFLAGS = ${LDFLAGS}"
echo "LIBS = ${LIBS}"
+echo "MAKEINFO = ${MAKEINFO}"
rm -f Makefile
cat > Makefile << EOF
# Makefile for Tarlz - Archiver with multimember lzip compression
-# Copyright (C) 2013-2022 Antonio Diaz Diaz.
+# Copyright (C) 2013-2023 Antonio Diaz Diaz.
# This file was generated automatically by configure. Don't edit.
#
# This Makefile is free software: you have unlimited permission
@@ -192,9 +196,10 @@ CPPFLAGS = ${CPPFLAGS}
CXXFLAGS = ${CXXFLAGS}
LDFLAGS = ${LDFLAGS}
LIBS = ${LIBS}
+MAKEINFO = ${MAKEINFO}
EOF
cat "${srcdir}/Makefile.in" >> Makefile
echo "OK. Now you can run make."
-echo "If make fails, verify that the compression library lzlib is correctly"
+echo "If make fails, check that the compression library lzlib is correctly"
echo "installed (see INSTALL)."