summaryrefslogtreecommitdiffstats
path: root/tox.ini
diff options
context:
space:
mode:
authorDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-02 08:20:07 +0000
committerDaniel Baumann <daniel.baumann@progress-linux.org>2024-03-02 08:20:07 +0000
commit3d2c9fd003c14a4969f383cd5eb0966b7b6a3d7b (patch)
tree96212b1fc6b9515e6bb63a5fc7869cb1da01d36d /tox.ini
downloadtqdm-3d2c9fd003c14a4969f383cd5eb0966b7b6a3d7b.tar.xz
tqdm-3d2c9fd003c14a4969f383cd5eb0966b7b6a3d7b.zip
Adding upstream version 4.64.1.upstream/4.64.1
Signed-off-by: Daniel Baumann <daniel.baumann@progress-linux.org>
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini88
1 files changed, 88 insertions, 0 deletions
diff --git a/tox.ini b/tox.ini
new file mode 100644
index 0000000..d77a5a8
--- /dev/null
+++ b/tox.ini
@@ -0,0 +1,88 @@
+# Tox (https://tox.testrun.org/) is a tool for running tests
+# in multiple virtualenvs. This configuration file will run the
+# test suite on all supported python versions. To use it, "pip install tox"
+# and then run "tox" from this directory.
+
+[tox]
+# deprecation warning: py{27,py2,34,35,36}
+envlist=py{27,34,35,36,37,38,39,310,py2,py3}{,-tf}{,-keras}, perf, setup.py
+isolated_build=True
+
+[gh-actions]
+python=
+ 2.7: py27
+ 3.5: py35
+ 3.6: py36
+ 3.7: py37
+ 3.8: py38
+ 3.9: py39
+ 3.10: py310
+ pypy-2.7: pypy2
+ pypy-3.7: pypy3
+[gh-actions:env]
+PLATFORM=
+ ubuntu: tf-keras
+
+[core]
+deps=
+ pytest
+ py3{4,5,6}: pytest<7
+ pytest-cov
+ pytest-timeout
+ py3{7,8,9,10}: pytest-asyncio
+ py3{6,7,8,9,10}: ipywidgets
+ py3{7,8,9,10}: git+https://github.com/casperdcl/nbval.git@master#egg=nbval
+ coverage
+ coveralls
+ codecov
+commands=
+ - coveralls
+ codecov -X pycov -e TOXENV
+ - codacy report -l Python -r coverage.xml --partial
+
+[testenv]
+passenv=TOXENV CI GITHUB_* CODECOV_* COVERALLS_* CODACY_* HOME
+deps=
+ {[core]deps}
+ cython
+ dask[delayed]
+ matplotlib
+ numpy
+ pandas
+ tf: tensorflow!=2.5.0
+ !py27-keras: keras
+ py27-keras: keras<2.5
+ py35-keras: keras<2.7
+ py27-tf: protobuf<3.18
+ py3{6,7,8,9,10}: rich
+commands=
+ py3{4,5,6}: pytest --cov=tqdm --cov-report=xml --cov-report=term -k "not perf" -o addopts= -v --tb=short -rxs -W=error --durations=0 --durations-min=0.1
+ py3{7,8,9,10}: pytest --cov=tqdm --cov-report= tests_notebook.ipynb --nbval --nbval-current-env -W=ignore --nbval-sanitize-with=setup.cfg
+ py3{7,8,9,10}: pytest --cov=tqdm --cov-report=xml --cov-report=term --cov-append -k "not perf"
+ {[core]commands}
+allowlist_externals=codacy
+
+[testenv:py{27,py2}{,-tf}{,-keras}]
+commands=
+ pytest --cov=tqdm --cov-report=xml --cov-report=term -k "not perf" -o addopts= -v --tb=short -rxs -W=error --durations=10
+ {[core]commands}
+
+# no cython/numpy/pandas
+[testenv:py{34,py2,py3}]
+deps={[core]deps}
+
+[testenv:perf]
+deps=
+ pytest
+ pytest-timeout
+ pytest-asyncio
+commands=pytest -k perf
+
+[testenv:setup.py]
+deps=
+ docutils
+ pygments
+ py-make>=0.1.0
+commands=
+ {envpython} setup.py check --restructuredtext --metadata --strict
+ {envpython} setup.py make none