summaryrefslogtreecommitdiffstats
path: root/environment.yml
diff options
context:
space:
mode:
Diffstat (limited to 'environment.yml')
-rw-r--r--environment.yml46
1 files changed, 46 insertions, 0 deletions
diff --git a/environment.yml b/environment.yml
new file mode 100644
index 0000000..871e3e8
--- /dev/null
+++ b/environment.yml
@@ -0,0 +1,46 @@
+# development environment
+name: tqdm
+channels:
+- conda-forge
+- defaults
+dependencies:
+# base
+- python=3
+- pip
+- ipykernel
+- ipywidgets
+- setuptools
+- setuptools_scm
+- toml
+# test env managers
+- pre-commit
+- tox
+- asv
+# tests (native)
+- pytest
+- pytest-cov
+- pytest-timeout
+- pytest-asyncio # [py>=3.7]
+- nbval
+- coverage
+# extras
+- dask # dask
+- matplotlib # gui
+- numpy # pandas, keras, contrib.tenumerate
+- pandas
+- tensorflow # keras
+- slack-sdk # contrib.slack
+- requests # contrib.telegram
+- rich # rich
+- argopt # `cd wiki && pymake`
+- twine # `pymake pypi`
+- wheel # `setup.py bdist_wheel`
+# `cd docs && pymake`
+- mkdocs-material
+- pydoc-markdown
+- pygments
+- pymdown-extensions
+- pip:
+ - py-make >=0.1.0 # `setup.py make/pymake`
+ - mkdocs-minify-plugin # `cd docs && pymake`
+ - git+https://github.com/tqdm/jsmin@python3-only#egg=jsmin # `cd docs && pymake`