summaryrefslogtreecommitdiffstats
path: root/recipe/meta.yaml
diff options
context:
space:
mode:
Diffstat (limited to 'recipe/meta.yaml')
-rw-r--r--recipe/meta.yaml25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipe/meta.yaml b/recipe/meta.yaml
new file mode 100644
index 0000000..7dad9ac
--- /dev/null
+++ b/recipe/meta.yaml
@@ -0,0 +1,25 @@
+package:
+ name: treelib
+ version: {{ environ['VERSION'] }}
+
+source:
+ git_url: git://github.com/caesar0301/treelib.git
+ git_tag: {{ environ['TAG'] }}
+
+build:
+ script: python setup.py install
+ string: {{ environ['BUILD_NAME'] }}
+ noarch: python
+
+about:
+ home: https://treelib.readthedocs.io/en/latest/
+ summary: An efficient implementation of tree data structure in python 2/3.
+
+requirements:
+ build:
+ - python
+ - setuptools
+ - pip
+
+ run:
+ - python