summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--debian/control1
-rwxr-xr-xdebian/rules1
2 files changed, 2 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 387a60d..8deecfa 100644
--- a/debian/control
+++ b/debian/control
@@ -7,6 +7,7 @@ Build-Depends:
debhelper-compat (= 13),
libjson-c-dev,
libwebsockets-dev,
+ yarnpkg,
zlib1g-dev,
Rules-Requires-Root: no
Standards-Version: 4.6.2
diff --git a/debian/rules b/debian/rules
index 453d005..5313c55 100755
--- a/debian/rules
+++ b/debian/rules
@@ -4,4 +4,5 @@
dh ${@} --builddirectory=build
override_dh_auto_build:
+ cd html && yarnpkg install && yarnpkg run build
mkdir -p build && cd build && cmake .. && make