summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--debian/control5
-rwxr-xr-xdebian/zutils.preinst2
2 files changed, 7 insertions, 0 deletions
diff --git a/debian/control b/debian/control
index 93cea68..bb449e2 100644
--- a/debian/control
+++ b/debian/control
@@ -18,6 +18,11 @@ Architecture: any
Depends:
${misc:Depends},
${shlibs:Depends},
+Breaks:
+# We must ensure that gzip is upgraded before zutils.postinst runs. As it is
+# essential, Breaks is sufficient here and the janitor may propose dropping
+# this relation eventually.
+ gzip (<< 1.12-1.1~),
Suggests:
bzip2,
lzip,
diff --git a/debian/zutils.preinst b/debian/zutils.preinst
index 557bdba..0b242e6 100755
--- a/debian/zutils.preinst
+++ b/debian/zutils.preinst
@@ -8,6 +8,8 @@ case "${1}" in
install)
for FILE in zcat zcmp zdiff zegrep zfgrep zgrep
do
+ # We may move $FILE to $FILE.gzip when we expected $FILE.gzip.usr-is-merged here.
+ # This is ok, because gzip will be upgraded and overwrite $FILE.gzip.
dpkg-divert --package zutils --quiet --add --rename --divert "/usr/bin/${FILE}.gzip" "/usr/bin/${FILE}"
dpkg-divert --package zutils --quiet --add --rename --divert "/bin/${FILE}.gzip.usr-is-merged" "/bin/${FILE}"
dpkg-divert --package zutils --quiet --add --rename --divert /usr/share/man/man1/${FILE}.gzip.1.gz /usr/share/man/man1/${FILE}.1.gz