summaryrefslogtreecommitdiffstats
path: root/debian/patches/0002-zupdate.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/0002-zupdate.patch')
-rw-r--r--debian/patches/0002-zupdate.patch15
1 files changed, 15 insertions, 0 deletions
diff --git a/debian/patches/0002-zupdate.patch b/debian/patches/0002-zupdate.patch
new file mode 100644
index 0000000..93e179f
--- /dev/null
+++ b/debian/patches/0002-zupdate.patch
@@ -0,0 +1,15 @@
+Author: Daniel Baumann <mail@daniel-baumann.ch>
+Description: Avoid linking zupdate statically.
+
+diff -Naurp zutils.orig/Makefile.in zutils/Makefile.in
+--- zutils.orig/Makefile.in
++++ zutils/Makefile.in
+@@ -53,7 +53,7 @@ ztest : ztest.in
+ chmod a+x ztest
+
+ zupdate : $(zupdate_objs)
+- $(CXX) $(LDFLAGS) -o $@ $(zupdate_objs)
++ $(CXX) -o $@ $(zupdate_objs)
+
+ main.o : main.cc
+ $(CXX) $(CPPFLAGS) $(CXXFLAGS) -DGREP=\"$(GREP)\" -c -o $@ $<